Welcome, Guest. Please login or register.
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy / VW Sharan / SEAT Alhambra Forum:

Author Topic: Airbag fault Galxy MK2  (Read 967 times)

Offline goelettom

  • *
  • Posts: 7
  • Thanked: 1
  • Model: Galaxy Mk2 Auto
  • Spec: '06 2.8 V6
  • First Name: Tom
  • Region: Non UK
  • Country: Netherlands
Airbag fault Galxy MK2
« on: April 03, 2018, 08:33:50 PM »
yesterday I removed the steering wheel airbag in my 2006 (mk2) Galaxy.
When I put it back, the airbaglight stayed on and the board computer said there was a airbag fault.

So I presume it must have something to do with the steering wheel airbag.

Today I removed it once again and checked everything. Then, I replaced the airbag with my other 2002 galaxy airbag. Still at fault.
So I guess it's not the airbag itself that is at fault.

Then I removed the plastic pieces behind the steering wheel so I could check the slipwheel (or whatever it is called in english?) The turning thing with the connectors on it.

I couldn't find anything wrong with that.

Only thing is: the airbag has a blue and a brown wire in the middle. As far as I can tell they are connected to each other in the connectorpin... (?) i i remove all connctors, and check the pinout on the slipring, on my 2002 Galaxy the first two pins are NOT connected to each other, and on my 2006 Galaxy they are connected.

After that, I found a small copper pin/plate in my 2002 Galaxy that looks like it could be used inside a connector to connect two pins together.

Soooo, it looks like I broke something in my 02 galaxy, but in that car all works fine. it's my 06 that has the airbag fault....

Does anybody have any idea what might have went wrong?
And what I could do to check it and repair it?

Hope anyone can help, thanks in advance!

Offline brianh

  • *
  • Posts: 805
  • Thanked: 74
  • Model: Galaxy Mk2
  • Spec: 2001 2.3 Ghia LPG
  • First Name: Brian
  • Region: South East
  • Country: United Kingdom
Re: Airbag fault Galxy MK2
« Reply #1 on: April 03, 2018, 08:57:56 PM »
You need VCDS to reset it - the lite version will do it. That will also tell you what the fault is, though if I had to take a guess you might have started it without the airbag connected at some point? Anyway you need vcds to clear the error once you've fixed the problem, so start by borrowing or buying a cable (any of the vag-com compatible cables on eBay should be fine and fairly cheap, then you just need the VCDS-lite download)

The metal clip might be the one that goes in the yellow connector - Its there to discharge the circuit when you unplug it, and only shorts the terminals together when unplugged.

Either that or you've broken the clock spring/Squib (both names for the bit you refer to as the slipwheel above) - Either way VCDS will narrow down the actual error, if your lucky it will just clear.

Offline goelettom

  • *
  • Posts: 7
  • Thanked: 1
  • Model: Galaxy Mk2 Auto
  • Spec: '06 2.8 V6
  • First Name: Tom
  • Region: Non UK
  • Country: Netherlands
Re: Airbag fault Galxy MK2
« Reply #2 on: April 03, 2018, 09:03:28 PM »
yes, I believe I was stupid enough to start it with the airbag disconnected.....  ???
I will check  VCDS out, I think I might have bought that a couple of months ago. Hope i can find it, I moved in the meantime :)

Thanks for the wonderful info!

Offline goelettom

  • *
  • Posts: 7
  • Thanked: 1
  • Model: Galaxy Mk2 Auto
  • Spec: '06 2.8 V6
  • First Name: Tom
  • Region: Non UK
  • Country: Netherlands
Re: Airbag fault Galxy MK2
« Reply #3 on: April 04, 2018, 07:34:18 PM »
So today I found my VCDS installation disc and cable, I found a working laptop, managed to install it and erased the fault codes on the airbag.

problem solved!

Thanks!

 

Related Topics

  Subject / Started by Replies Latest
6 Replies
6283 Views
Latest February 18, 2014, 12:48:36 PM
by alexk
5 Replies
2905 Views
Latest June 11, 2014, 10:48:53 PM
by Hilborn
3 Replies
2561 Views
Latest June 21, 2015, 10:36:41 PM
by gregers
2 Replies
1758 Views
Latest December 16, 2016, 09:04:26 PM
by Mirez
0 Replies
2072 Views
Latest November 30, 2017, 09:47:03 AM
by mike wilson
13 Replies
1335 Views
Latest May 18, 2018, 12:32:54 PM
by brianh

Advertisement:


SMF spam blocked by CleanTalk