Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca?

Mk1 and Mk2 VW Sharan Mk1 and Mk2 Ford Galaxy Mk1 and Mk2 SEAT AlhambraFord C-Max B-MaxVW Tiguan VW Touran Mk3 Ford GalaxyMk3 VW SharanMk3 SEAT AlhambraVW T4 T5 Caravelle TransporterFord Tourneo Connect VW Touareg

Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy / VW Sharan / SEAT Alhambra Forum:

Author Topic: AUX Heater (eberspacher) diesel pump  (Read 1648 times)

Offline jimmyuk

  • Default User Group
  • New Users
  • *
  • Posts: 3
  • Thanked: 0
  • Model: Sharan Mk2
  • Spec: 06 TDI 140
  • Region: East Midlands
  • Country: United Kingdom
AUX Heater (eberspacher) diesel pump
« on: March 05, 2018, 08:57:01 AM »
Hi,

Car: 2006 VW Sharan 2.0TDI 140

After tinkering with the eberspacher on and off for a couple of years I have finally got it running... of sorts.

I have located the problem as the fuel pump. It kept getting "flame out" when trying to start. Today I took the wires off the fuel pump and connected them to a 12v power source. The pump clicked, i reset the error codes on the eberspacher and the thing kicked out plenty of white smoke and started up.

While i had the battery connected to the pump directly I had a multi meter connected to the car's input to the pump and it wasn't showing any voltage. I have concluded that the pump is working as it should however it's not getting the power to turn on. I can see that the eberspacher is requesting the eberspacher to turn on on VCDS however it's just not getting any power.

I have 2 questions,

1: Where is the power for the pump coming from? is there a fuse anywhere? or any idea what I need to be looking for, the connector to the eberspacher seems to be in good condition.

2: The pump it's self, should it just clunk on and clunk off with no 'running' sound? when 12v is applied to the pump it just clunks once and then clunks again when 12v is removed. More like a solenoid than a pump.

Thanks
Jimmy

Offline johnnyroper

  • RL Contributor
  • Accredited Users
  • *
  • Posts: 3241
  • Thanked: 170
  • Model: Galaxy Mk2
  • Spec: 02 tdi 115 ghia
  • Region: South West
  • Country: United Kingdom
Re: AUX Heater (eberspacher) diesel pump
« Reply #1 on: March 05, 2018, 09:31:28 AM »
The pump does just make a clicking noise and not humming like a typical motor driven pump.
As you got the heater to run that rules out fuses in my opinion as the whole heater would be dead.

Power for the dosing pump comes from the control unit on the boost heater, is yours the newer type with control unit on the top? If it is I would suspect the control unit is knackered due to its location,they suffer with damage from the heat build up.

It’s worth continuity testing the dosing pump wiring back to control unit to eliminate wire breaks first though.

Offline Chrispb

  • Mindsaysyesbodysaysnono
  • Administrator
  • Accredited Users
  • *
  • Posts: 3098
  • Thanked: 122
  • Model: Galaxy Mk2 Auto
  • Spec: 52reg TDI 115 Ghia
  • First Name: Chris
  • Region: South East
  • Country: United Kingdom
Re: AUX Heater (eberspacher) diesel pump
« Reply #2 on: March 05, 2018, 10:30:45 AM »
The pump should receive pulsed voltage from the booster heaters control unit this is more noticeable ticking when the heater initializes, as your car is a 2006 then you'll most likely have the D5Z-F heater and as johnnyroper said suffers with control unit failure and gives odd error codes.

check the multi plug on the heater for corrosion but to be honest the only wire I've seen with that problem is the large red wire which is the heater power supply 
2016 Vauxhall Insignia Elite Nav in White 2.0CDTI Manual.
2009 Kia Sedona GS In Black 2.9CRDI 183PS. 5 Speed Manual WAV.
2003 MK2 Galaxy Ghia In Solid Black 1.9 TDI 115PS. 5 Speed Automatic.

Upgraded Eberspaecher booster heater  to independent heating with 7 day timer.

With VCDS lite (full version) need a code clearing or want to scan for faults in the north kent area, PM me.
All for a pint of Strongbow.

The FordMPV.com Forum - The free forum for questions and answers relating to the Ford Galaxy, S-Max and C-Max

Offline jimmyuk

  • Default User Group
  • New Users
  • *
  • Posts: 3
  • Thanked: 0
  • Model: Sharan Mk2
  • Spec: 06 TDI 140
  • Region: East Midlands
  • Country: United Kingdom
Re: AUX Heater (eberspacher) diesel pump
« Reply #3 on: March 09, 2018, 04:26:39 PM »
Thanks for all your input. I will test the connections. must just be a bad one

 

Related Topics

  Subject / Started by Replies Last post
0 Replies
14808 Views
Last post February 03, 2012, 10:38:11 PM
by Chrispb
13 Replies
7812 Views
Last post March 05, 2014, 11:35:51 AM
by Chrispb
15 Replies
7381 Views
Last post June 10, 2014, 01:21:28 AM
by insanitybeard
6 Replies
4321 Views
Last post February 02, 2015, 11:53:30 AM
by bigjeeze
2 Replies
2049 Views
Last post April 12, 2017, 08:23:12 PM
by the5krunner
3 Replies
1493 Views
Last post January 10, 2018, 09:10:38 PM
by Mirez

Advertisement: