FordMPV Forum

Large MPVs -- Ford Galaxy / VW Sharan / SEAT Alhambra: => Ford Galaxy / VW Sharan / SEAT Alhambra => Topic started by: blue metal on March 31, 2014, 12:53:19 PM

Title: brake wear indicator
Post by: blue metal on March 31, 2014, 12:53:19 PM
Just fitted new front discs and pads.
Now have brake wear light coming on
intermittently
it clears and resets when switched ignition off

any special points that I should look for?

Tony
Title: Re: brake wear indicator
Post by: Chrispb on March 31, 2014, 01:38:51 PM
Hi Tony
If it was OK before then it has to be a bad connection where the lead plugs in. iirc just the N/S
Title: Re: brake wear indicator
Post by: insanitybeard on April 01, 2014, 12:09:22 AM
I think mysterious brake pad warning light coming on / going out again issues are fairly common, perhaps Silverbeast can chime in because I think he's had it as well, but mine went through a stage of doing it backalong- the lamp would come on only to go out the next time I turned the ignition off and then on again, the pads have plenty of life left in them and it's stopped doing it now and I've not done anything to change anything so I don't really know why!
Title: Re: brake wear indicator
Post by: SilverBeast on April 01, 2014, 12:27:38 AM
Mine was a cracked connector on the pads where it plugs into the wiring on the offside front wheel.  When I disconnected it it left the two pins sticking out.  I managed to glue the shell back together and it's been fine since.
Title: Re: brake wear indicator
Post by: blue metal on April 01, 2014, 01:57:02 PM
Thanks I will check that out
again
When I tried this morning
nofault showed.
hear's hoping

Tony
Title: Re: brake wear indicator
Post by: Chrispb on April 01, 2014, 02:19:08 PM
Mine was a cracked connector on the pads where it plugs into the wiring on the offside front wheel.  When I disconnected it it left the two pins sticking out.  I managed to glue the shell back together and it's been fine since.
Are you saying you have wear indicators on all four wheels, I've only seen them on n/s/front and o/s/rear wheels
Title: Re: brake wear indicator
Post by: Mirez on April 01, 2014, 04:50:35 PM
Mines got them on all four wheels although my last Mk2 only had two (N/S Front and O/S Rear)
Title: Re: brake wear indicator
Post by: blue metal on April 01, 2014, 06:48:16 PM
just to confirm
one at front one at rear
no more fault at present
leave alone just now
Title: Re: brake wear indicator
Post by: Grant2012 on April 01, 2014, 07:10:20 PM
I got 4. Had to short em all out as new pads had none
Title: Re: brake wear indicator
Post by: SilverBeast on April 01, 2014, 07:12:16 PM
Are you saying you have wear indicators on all four wheels, I've only seen them on n/s/front and o/s/rear wheels
Quite right my mistake. It was nearside front. I have just the two!