Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy / VW Sharan / SEAT Alhambra Forum:

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca?

Mk1 and Mk2 VW Sharan Mk1 and Mk2 Ford Galaxy Mk1 and Mk2 SEAT AlhambraFord C-Max B-MaxVW Tiguan VW Touran Mk3 Ford GalaxyMk3 VW SharanMk3 SEAT AlhambraVW T4 T5 Caravelle TransporterFord Tourneo Connect VW Touareg

Author Topic: coolant fans sometimes run after ignition off and drains battery?  (Read 5449 times)

Offline shrek

  • Default User Group
  • Standard Users
  • *
  • Posts: 8
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 01 ghia
as the title states not all the time but the radiator fans will run after engine is switched off and without knowing it drains the battery. im pretty sure they randomly start but its getting annoying now having to jump start the car. not really sure where to start or if its a common fault but really need to get it sorted now, car is a galaxy mk2 2.3 ghia petrol

thanks

Offline insanitybeard

  • Greetings from Mr Chick!
  • Global Moderator
  • Accredited Users
  • *
  • Posts: 2453
  • Thanked: 74
  • Model: Galaxy Mk2
  • Spec: '54 130ps TDI Ghia
  • First Name: Paul
  • Region: South West
  • Country: United Kingdom
Re: coolant fans sometimes run after ignition off and drains battery?
« Reply #1 on: August 12, 2014, 06:49:09 pm »
Do you know how long the fans continue to run on for once the engine/ignition is turned off? This is normal in some cars but I'm not sure if it is with the 2.3 petrol, it'll need somebody else to clarify that. If it isn't normal it could be a defective fan control module, which I think is mounted near or in the fan cowling itself.
Always learning..... Often by mistakes!

Offline shrek

  • Default User Group
  • Standard Users
  • *
  • Posts: 8
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 01 ghia
Re: coolant fans sometimes run after ignition off and drains battery?
« Reply #2 on: August 12, 2014, 08:09:21 pm »
When it does stay on it will run until the battery is dead completely as said it doesn't happen all the time but it's happened twice now in a week

Offline Mirez

  • Pondering the next mod...
  • Webmaster
  • Accredited Users
  • *
  • Posts: 3774
  • Thanked: 180
  • Model: Galaxy Mk2
  • Spec: 03 115PS Ghia
  • First Name: Mark
  • Region: South West
  • Country: United Kingdom
Re: coolant fans sometimes run after ignition off and drains battery?
« Reply #3 on: August 12, 2014, 08:16:48 pm »
There were multiple revisions to the wiring for the radiator fans so I can't give you any wiring advise - use www.etis.ford.com to get an exact build date for your car.
03 Ford Galaxy 1.9 TDI 115 Ghia in Spruce Green Metallic
With cream leather interior, Full Bodykit, Remapped at 145bhp, Lowered on 18's
08 Ford Transit 2.2 TDI 115 in Frozen White
With retrofitted everything except another slidey door! :)

LAUNCH X431 Pad PRO - Scanning & Coding for all makes and models done in Wiltshire in exchange for winegums! :)

Offline shrek

  • Default User Group
  • Standard Users
  • *
  • Posts: 8
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 01 ghia
Re: coolant fans sometimes run after ignition off and drains battery?
« Reply #4 on: August 12, 2014, 08:45:28 pm »
Any good ???


Primary Features
Build Date:     29.01.2001
Vehicle Line:     Galaxy 2000-2006
Body Style:     5 Door Saloon
Version:     High Series
Engine:     2.3L DOHC (145PS)
Transmission:     5-Speed Manual Transaxle - VXT75
Drive:     RHD FWD
Axle Ratio:     4.24
Emission:     With Stage III Emission Requirement
Air Conditioning:     Automatic Air Conditioning
Territory:     (+)"GB"
Paint:     Pacific Green Med Solid
Interior Fabric:     Kenzo / Anthracite

Offline Mirez

  • Pondering the next mod...
  • Webmaster
  • Accredited Users
  • *
  • Posts: 3774
  • Thanked: 180
  • Model: Galaxy Mk2
  • Spec: 03 115PS Ghia
  • First Name: Mark
  • Region: South West
  • Country: United Kingdom
Re: coolant fans sometimes run after ignition off and drains battery?
« Reply #5 on: August 12, 2014, 09:12:06 pm »
Any good ???
Build Date:     29.01.2001

Yeah :)

So you have a control relay in the engine bay, and also a thermo switch either in the radiator or on one of its inlets.  Start by finding that switch and then measure it when disconnected. It should have a very low resistance, if its high then it will be tricking the control relay into putting the fan on.
03 Ford Galaxy 1.9 TDI 115 Ghia in Spruce Green Metallic
With cream leather interior, Full Bodykit, Remapped at 145bhp, Lowered on 18's
08 Ford Transit 2.2 TDI 115 in Frozen White
With retrofitted everything except another slidey door! :)

LAUNCH X431 Pad PRO - Scanning & Coding for all makes and models done in Wiltshire in exchange for winegums! :)

Offline shrek

  • Default User Group
  • Standard Users
  • *
  • Posts: 8
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 01 ghia
Re: coolant fans sometimes run after ignition off and drains battery?
« Reply #6 on: August 12, 2014, 10:21:36 pm »
Ok thanks for the help   will have a mooch on auto data see if I can get a rough idea as to the placement of the switch then go from there thanks again
« Last Edit: August 12, 2014, 10:23:33 pm by shrek »

Offline Mirez

  • Pondering the next mod...
  • Webmaster
  • Accredited Users
  • *
  • Posts: 3774
  • Thanked: 180
  • Model: Galaxy Mk2
  • Spec: 03 115PS Ghia
  • First Name: Mark
  • Region: South West
  • Country: United Kingdom
Re: coolant fans sometimes run after ignition off and drains battery?
« Reply #7 on: August 15, 2014, 06:51:14 pm »
Bizarrely, mines also started doing this yesterday and today! Disconnecting the relay stops the fans (as you'd expect) so further investigation needed!
03 Ford Galaxy 1.9 TDI 115 Ghia in Spruce Green Metallic
With cream leather interior, Full Bodykit, Remapped at 145bhp, Lowered on 18's
08 Ford Transit 2.2 TDI 115 in Frozen White
With retrofitted everything except another slidey door! :)

LAUNCH X431 Pad PRO - Scanning & Coding for all makes and models done in Wiltshire in exchange for winegums! :)

Offline SilverBeast

  • RL Contributor
  • Accredited Users
  • *
  • Posts: 499
  • Thanked: 14
  • Model: Galaxy Mk2
  • Spec: '05 TDI (130) Ghia
  • Region: Yorkshire
Re: coolant fans sometimes run after ignition off and drains battery?
« Reply #8 on: August 15, 2014, 09:08:23 pm »
Our handyman at work has a similar problem with a Rover 75. One of the speed control relays sticks on.

Offline shrek

  • Default User Group
  • Standard Users
  • *
  • Posts: 8
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 01 ghia
Re: coolant fans sometimes run after ignition off and drains battery?
« Reply #9 on: October 13, 2014, 08:29:48 pm »
Well I never really got round to fixing this problem as it kinda fixed itself but it's come back to haunt me ! Now I've Sussed out the fan stays on if the if the heater is put on LO for aircon? Now the fan that runs I thought was the engine cooling fan, so anyone know where the relay is please

Offline shrek

  • Default User Group
  • Standard Users
  • *
  • Posts: 8
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 01 ghia
Re: coolant fans sometimes run after ignition off and drains battery?
« Reply #10 on: October 13, 2014, 09:49:30 pm »
Actually just found this which is stop on info and hopefully will be what I'm after

https://www.fordmpv.com/smf2/ford-galaxy-reference-library/ford-galaxy-radiator-fan-staying-on-diagnosing-2002-on-cars/

Hopefully this will help others

 

Related Topics


Advertisement: