Welcome, Guest. Please login or register.
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

Advertisement:


Recent Forum Topics:

Google Translate:

Ford Galaxy / VW Sharan / SEAT Alhambra Forum:

Author Topic: electrical problem, no speedo or rev counter,fuel temp gauge needles problem  (Read 4682 times)

Offline andy247gtr

  • *
  • Posts: 2
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 02 1.9 tdi zetec
i,ve got a weird problem, lost speedo,rev counter and fuel and temp gauge needles go round nearly 180 degree's over readings. also lost mileage reading, only getting oooooo and "def" message on lcd display and km now reading in bottom corner.
 on switching on ignition get an audible beep initially. this suddenly happened after a very cold night and frosty morning.
everything else on car works ok, but did notice when driving with fan, all demisters and headlights on when driving at about 60 mph car suddenly felt like power lost for a second or two. not noticed that again yet??
has anyone come across this fault before? wondered if it might be an earth fault somewhere maybe? help!!

Offline Chrispb

  • Mindsaysyesbodysaysnono
  • *
  • Posts: 2980
  • Thanked: 91
  • Model: Galaxy Mk2 Auto
  • Spec: 52reg TDI 115 Ghia
  • First Name: Chris
  • Region: South East
  • Country: United Kingdom
 welcome5 andy247gtr

The fact that the mileage has gone to zero would suggest fault is in the cluster which could also cover the other problems with display, the sudden power loss may or may not be related.
You best do a scan for fault codes as you may have a boost problem or other related fault.
2009 Kia Sedona GS In Black 2.9CRDI 183PS. 5 Speed Manual WAV.
2003 MK2 Galaxy Ghia In Solid Black 1.9 TDI 115PS. 5 Speed Automatic.

Upgraded Eberspächer booster heater  to independent heating with 7 day timer.

With VCDS lite (full version) need a code clearing or want to scan for faults in the north kent area, PM me.
All for a pint of Strongbow.

The FordMPV.com Forum - The free forum for questions and answers relating to the Ford Galaxy, S-Max and C-Max

Offline andy247gtr

  • *
  • Posts: 2
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 02 1.9 tdi zetec
thanks chrispb for your message,see what i find. cheers!
 

 

Related Topics

  Subject / Started by Replies Latest
3 Replies
3452 Views
Latest September 29, 2014, 10:21:52 AM
by Chrispb
4 Replies
3764 Views
Latest May 31, 2015, 05:50:52 PM
by scottgunn88
2 Replies
3908 Views
Latest June 17, 2015, 06:04:45 PM
by insanitybeard
2 Replies
2048 Views
Latest August 25, 2015, 05:31:21 PM
by RossT
1 Replies
1441 Views
Latest July 20, 2016, 06:35:24 PM
by johnnyroper
5 Replies
1737 Views
Latest August 21, 2017, 07:21:22 PM
by johnnyroper

Advertisement: