Welcome, Guest. Please login or register.
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy / VW Sharan / SEAT Alhambra Forum:

Author Topic: electricalnight mare  (Read 2639 times)

Offline Liam

  • *
  • Posts: 1
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 06 tdi ztec 115
  • Region: South West
electricalnight mare
« on: April 06, 2015, 01:56:26 PM »
Just wondering if anyone has any ideas.
our electrics have been starting to play up a bit, at first it was the auxilary heater that kept on shorting out worked this by removing the fuse problem solved. however now after a month or so other things have gone haywire the horn and indicators have stopped working (fuses are fine and hazards work) and the AC wont come on Along with the screen de mist/ air circulation control.in adition to this the abs and handbrake lights will not go out on dash board is this likely to be a fuse board problem or a ecu, really struggling to work it out.
could really appreciate some input
« Last Edit: April 06, 2015, 01:59:06 PM by Liam »

Offline Chrispb

  • Mindsaysyesbodysaysnono
  • *
  • Posts: 3024
  • Thanked: 112
  • Model: Galaxy Mk2 Auto
  • Spec: 52reg TDI 115 Ghia
  • First Name: Chris
  • Region: South East
  • Country: United Kingdom
Re: electricalnight mare
« Reply #1 on: April 06, 2015, 03:36:43 PM »
Hello and  welcome5

Have you looked in the battery fuse box is there any signs of burning/melting, also check the purple fuse 3 amp.
2009 Kia Sedona GS In Black 2.9CRDI 183PS. 5 Speed Manual WAV.
2003 MK2 Galaxy Ghia In Solid Black 1.9 TDI 115PS. 5 Speed Automatic.

Upgraded Eberspächer booster heater  to independent heating with 7 day timer.

With VCDS lite (full version) need a code clearing or want to scan for faults in the north kent area, PM me.
All for a pint of Strongbow.

The FordMPV.com Forum - The free forum for questions and answers relating to the Ford Galaxy, S-Max and C-Max

Offline timhowarduk

  • *
  • Posts: 7
  • Thanked: 0
  • Model: Alhambra Mk2
  • Spec: 03 1.9 TDCI
  • First Name: Tim
  • Region: North West
Re: electricalnight mare
« Reply #2 on: April 11, 2015, 08:48:31 PM »
I had totally random electrical problems in another car once. OK, it was a Citroen... but the digital dashboard, speedo, central locking, cruise control, all manner of electrical things that were apparently unrelated to each other would all stop working at random.
After spending far too much money with auto electrical people and main dealers over 18 months, on a longer run I was stunned to find my wife could break the car at will by swapping from radio to CD. Got home, removed stereo, and the car behaved fine. I was pretty speechless about this, then I found there was a penny inside the CD slot rolling around and shorting things out. Which suddenly explained why taking a certain left turn on 2 wheels sometimes fixed the car.

As well as looking for signs or smells of burning, I'd be inclined to look in the compartments under the two front seats for signs of water ingress. Best of luck.

 

Related Topics

  Subject / Started by Replies Latest
0 Replies
1398 Views
Latest August 11, 2017, 08:27:19 AM
by 2006ransome

Advertisement:


SMF spam blocked by CleanTalk