Welcome, Guest. Please login or register.
Did you miss your activation email?
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy / VW Sharan / SEAT Alhambra Forum:

Author Topic: few electrical issues  (Read 915 times)

Offline graham

  • *
  • Posts: 13
  • Thanked: 1
  • Model: Alhambra Mk1
  • Spec: 20vt
  • First Name: graham
  • Region: South West
few electrical issues
« on: August 13, 2018, 10:37:38 AM »
ok, had the car a few weeks, fixed a fgew basic things (dipstick broken, split hose, blah blah) and on a long journey the airbag light came on. i decided to plug a scanner in and link error, now, this was a new scanner, but has worked on ym x reg fabia flawlessley, as have the few diff elm327's i have nocking about. cant find my usb cable so ordered a cheapo to give vcds a try. while i wait i thought id sniff around the kline, there is a stock stereo in there might i add (with cd changer, i plan on removing and checking k line today) i measured kline at pins 7 and 16 and found full batt on 16 and around 11v on 7. past this the ross tech site says "bridge a resistor and feel it warm up" erm, no thanks. now, ive had similar issues with airbags befor, specifically wet footwwells but this all feels dry as a bone, i also ajusted the steering wheel between the light beimng off and it being on *unsure how long it went unnoticed tbh) so, few questuions,
1, does the k line seem normal/do these have trouble with newer readers?
2, where is all the airbag wiring/componants hidden? im going to go through every connector but where to look would be nice, they have sensors in the doors too im led to believe
3, is there a manual for this car?!!
4, has anyone had similar issues?
5 where are the modules hiding on this car?
6, where is the diverter valve hiding on this car LOL

sorry for the long winded one, thought id get it all out in one as there mostly relitive
cheers all

Offline brianh

  • *
  • Posts: 806
  • Thanked: 74
  • Model: Galaxy Mk2
  • Spec: 2001 2.3 Ghia LPG
  • First Name: Brian
  • Region: South East
  • Country: United Kingdom
Re: few electrical issues
« Reply #1 on: August 13, 2018, 05:05:13 PM »
Struggling to read that! But the bit about airbags if the light is on it will stay on till you go in and reset the fault detected, even if you've fixed the fault it still needs clearing to get rid of it. VCDS lite will do that with a suitable lead (not the elm327 one you have already!).

The usual failure that causes the airbag light to come on is a failed clockspring, it does move every time you turn the steering wheel so hardly surprising.

K line question - don't know

Airbag wiring and ecu as far as i know is under the dashboard. I wouldn't go to the effort of finding it until you've read fault codes with vcds though as its probably wasted effort. Some may/will be different between Seat and Ford versions though.

Manual - there should be a user guide with the car, but its probably been lost or isn't what your after. Haynes do a manual for the mk1, but it only covers the 2.0 and 2.3 ford engines, and the diesel ones. I think (though not 100% sure on this) that you have a 2.0l petrol Seat engine which is completely different to the Ford ones (unlike the diesel which is only a badged VW engine in the Ford version). Though to be fair you probably don't actually need one as its not much help if you do have it.

Given its pre 2001 its not forced to communicate with standard obd tools - The Ford versions work on iso-j1850 PWM which is an oddball protocal, I'd suspect but don't know for sure that the VW/Seat versions work on something equally awkward, VCDS should fix that though.

Offline graham

  • *
  • Posts: 13
  • Thanked: 1
  • Model: Alhambra Mk1
  • Spec: 20vt
  • First Name: graham
  • Region: South West
Re: few electrical issues
« Reply #2 on: August 16, 2018, 09:07:39 PM »
i got to the bottom of both issues and yes it didnt like anything new in the obd socket. airbag was an intermitant earth, found some oil on the connector so cleaned. got another vag com cable (409.1 kkl) and cleared the code. this car really is a bit of an oddball (its a 1.8t not 2.0) forged crank, big valves, cable throttle, struggling to find out anything on this really, its even got a rather unique me version ecu (m.3.8.5) and i think its a crossover specific to this car so info on flashing is out the window. my next port of call is to see if a cable driven me7x ecu will just plug in for obd port flashing as this one looks to be a pain. ether way it will be getting an sai/n249/combivalve delete and pipe simplification, maybe a catch can. clutch slips at the standard 150 so thatl have to go in the bin for a stiff single mass as per usual. just want the thing how it should be, without all the tired junk pipework!> these 18t engines are just strangled with nonsense in the name of emmissions, and even then it only works for a few years untill removing it becomes a cleaner running option. will keep the thread updated

Offline brianh

  • *
  • Posts: 806
  • Thanked: 74
  • Model: Galaxy Mk2
  • Spec: 2001 2.3 Ghia LPG
  • First Name: Brian
  • Region: South East
  • Country: United Kingdom
Re: few electrical issues
« Reply #3 on: August 16, 2018, 11:17:17 PM »
There doesn't seem to be a lot of info about on the petrol Seat/VW versions, certainly not as much as the Ford Petrol ones has around. Anything you can post in the way of useful info may be useful to someone.

Offline graham

  • *
  • Posts: 13
  • Thanked: 1
  • Model: Alhambra Mk1
  • Spec: 20vt
  • First Name: graham
  • Region: South West
Re: few electrical issues
« Reply #4 on: December 15, 2018, 05:43:32 PM »
i have been meaning to do a lil project or write up on all my mods and discoverys, im getting to know this vehicle quite well and may be doing an ecu swap soon to something newer/more flashable so will have plenty of "been there done that" info for the board. already done clutch, that was a joke/hardest clutch ive ever done simply because of possition.

 

Related Topics

  Subject / Started by Replies Latest
4 Replies
5188 Views
Latest March 21, 2012, 11:47:23 PM
by Chrispb
1 Replies
2024 Views
Latest October 29, 2015, 07:16:42 PM
by Mirez
4 Replies
2525 Views
Latest March 15, 2016, 12:46:24 PM
by antzatgalalxy
2 Replies
1880 Views
Latest April 08, 2016, 09:14:39 PM
by Smithsonpaul
15 Replies
342 Views
Latest August 21, 2020, 10:38:51 PM
by SirDavidAlhambra
9 Replies
129 Views
Latest September 21, 2020, 06:59:58 PM
by brianh

Advertisement:


SMF spam blocked by CleanTalk