Welcome, Guest. Please login or register.
Did you miss your activation email?
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy / VW Sharan / SEAT Alhambra Forum:

Author Topic: Ford Galaxy has problem with ventilator..  (Read 4619 times)

Offline eddyyss

  • *
  • Posts: 18
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 1.9 TDi
  • Region: Non UK
Ford Galaxy has problem with ventilator..
« on: November 24, 2014, 08:17:18 PM »
Hi there,

Galaxy has problem with ventilator.

Like when I put on level 4 (speed) the ventilator shuts straight off and won't give me any air either hot and cold.

When I put on level 3 the A/C turns on... sometimes..

Also when I stop the engine wait for about 1-2 min and start again the ventilator works fine but again after couple min it shuts down to any level..

What could be a problem ?

Car - ford galaxy 1.9 TDi year 2001

Thank you!

Offline insanitybeard

  • Greetings from Mr Chick!
  • *
  • Posts: 2427
  • Thanked: 71
  • Model: Galaxy Mk2
  • Spec: '54 130ps TDI Ghia
  • First Name: Paul
  • Region: South West
  • Country: United Kingdom
Re: Ford Galaxy has problem with ventilator..
« Reply #1 on: November 24, 2014, 09:56:30 PM »
Greetings!

I'm assuming you mean the blower fan isn't working properly? If it's working on some speeds and not others the usual culprit is the resistor pack that regulates the fan motor speed, it eventually burns out with use. Usually it's mounted somewhere in the heater/blower box housing/ducting (accessed from the passenger side up and under the dash) so that the air being blown by the fan motor cools it  when in use.
Always learning..... Often by mistakes!

Offline eddyyss

  • *
  • Posts: 18
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 1.9 TDi
  • Region: Non UK
Re: Ford Galaxy has problem with ventilator..
« Reply #2 on: November 25, 2014, 12:57:57 AM »
yes blower fan. It works but it shuts off after couple min..

What would be the next step to check whats the problem ?

I have read on internet that i should check fuses (which I will do), replace Resistor Blower or it could be blower on it self...
« Last Edit: November 25, 2014, 01:04:31 AM by eddyyss »

Offline insanitybeard

  • Greetings from Mr Chick!
  • *
  • Posts: 2427
  • Thanked: 71
  • Model: Galaxy Mk2
  • Spec: '54 130ps TDI Ghia
  • First Name: Paul
  • Region: South West
  • Country: United Kingdom
Re: Ford Galaxy has problem with ventilator..
« Reply #3 on: November 25, 2014, 08:59:13 AM »
You say yours is a 2001 but a Mk1 model in your vehicle description.... If it's 2001 I'm thinking it may be a Mk2. You can find secondhand heater resistor packs on [eBay], if the blowers are working on some speeds and not others then I'd check this first, though usually speed number 4 doesn't use the resistor to reduce the fan speed as it runs at full speed on this setting. If the fan works at all then it's unlikely to be fuses, if a fuse had gone I wouldn't expect it to work at all. Yes the fan motor itself could be temperamental but trust me, it'll be quicker, cheaper and easier to check out/substitute the resistor pack first- that's usually the main component to give trouble!

If it's a Mk2, the resistor pack normally takes this form.
« Last Edit: November 25, 2014, 10:20:40 AM by insanitybeard »
Always learning..... Often by mistakes!

Offline eddyyss

  • *
  • Posts: 18
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 1.9 TDi
  • Region: Non UK
Re: Ford Galaxy has problem with ventilator..
« Reply #4 on: November 25, 2014, 03:47:59 PM »
Yes, it's year 2001, sorry I didn't know about mk1 and mk2, found on google that I have a MK2 as you said.

as I am helping my friend out on internet with his car  (car is 600 miles away), he asked if there is any way how to check if resistor pack  needs to be replaced ? He said he will take out radio and front panel so he can access to manual switch (for heat,speed etc.) check them first... he also said that he smelled some burned cable from the front... and  this problems with speed 3 and 4 he already had in summer but it was really really rarely...




Offline eddyyss

  • *
  • Posts: 18
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 1.9 TDi
  • Region: Non UK
Re: Ford Galaxy has problem with ventilator..
« Reply #5 on: November 26, 2014, 11:43:39 PM »
anyone ?

Offline insanitybeard

  • Greetings from Mr Chick!
  • *
  • Posts: 2427
  • Thanked: 71
  • Model: Galaxy Mk2
  • Spec: '54 130ps TDI Ghia
  • First Name: Paul
  • Region: South West
  • Country: United Kingdom
Re: Ford Galaxy has problem with ventilator..
« Reply #6 on: November 27, 2014, 09:09:44 AM »
If you're lucky then the old resistor pack will have evidence of overheating when it's taken out and inspected- burning or melting of the pack or connector where it connects to it. If not then you'll either have to bite the bullet and buy a known good secondhand part to substitute or bridge some of the contacts in the connector and power the fan motor up manually, see if it behaves itself.
Always learning..... Often by mistakes!

Offline eddyyss

  • *
  • Posts: 18
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 1.9 TDi
  • Region: Non UK
Re: Ford Galaxy has problem with ventilator..
« Reply #7 on: December 01, 2014, 10:19:38 PM »
It seems problem solved.

He took out the front panel (where is the manual temperature from low to how and levels from 1 to 4), apparently the cable was off, now all four levels work as new.. so I assume that's fixed... I hope..

 

Related Topics

  Subject / Started by Replies Latest
0 Replies
9194 Views
Latest February 03, 2012, 10:34:03 PM
by gregers
2 Replies
5110 Views
Latest November 25, 2012, 06:40:19 PM
by andy247gtr
2 Replies
2152 Views
Latest October 30, 2014, 09:18:22 PM
by gregers
2 Replies
2631 Views
Latest August 30, 2015, 09:33:44 AM
by Arvin Starr
5 Replies
3873 Views
Latest September 04, 2015, 08:31:08 PM
by Mirez
2 Replies
903 Views
Latest December 27, 2018, 08:04:18 PM
by gregers

Advertisement: