Welcome, Guest. Please login or register.
Did you miss your activation email?
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy / VW Sharan / SEAT Alhambra Forum:

Author Topic: galaxy mk2  (Read 3205 times)

Offline anthonydevanney

  • *
  • Posts: 11
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 2002 1.9 tdi zetec
  • Region: Yorkshire
galaxy mk2
« on: January 30, 2016, 06:31:46 PM »
Hi guys bought a 2002 galaxy 1.9 tdi tuesday i got back home and next speedo wasnt working didnt move at all the fuel gauge stays at right place for a few seconds then drops to empty making car beep then goes back up and continues doing so entire journey the temp seems to be working fine and rev counter also have no heating i had water pump changed and new thermostat but been told could be head causing no heat in car i did pour some k seal to seal head but still nothing any advice guys thanks

Offline anthonydevanney

  • *
  • Posts: 11
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 2002 1.9 tdi zetec
  • Region: Yorkshire
Re: galaxy mk2
« Reply #1 on: January 30, 2016, 07:06:45 PM »
Also the analogue clock on dash does not work checked fuse 32 and not blown

Offline johnnyroper

  • *
  • Posts: 2982
  • Thanked: 150
  • Model: Galaxy Mk2
  • Spec: 02 tdi 115 ghia
  • Region: South West
  • Country: United Kingdom
Re: galaxy mk2
« Reply #2 on: January 30, 2016, 09:22:00 PM »
Firstly have a check of door looms where their go in to doors if damaged can cause all sorts of problems.

As for heating check restrictor in small hose to top of expansion bottle isn't blocked,especially as k seal used. If the restrictor is blocked it won't allow air in cooling system to bleed out.

Offline anthonydevanney

  • *
  • Posts: 11
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 2002 1.9 tdi zetec
  • Region: Yorkshire
Re: galaxy mk2
« Reply #3 on: January 30, 2016, 09:57:22 PM »
Ok will check pipe in morning i just noticed on back driver side window some like clip similar to the fat battery clips it was unplugged so i plugged it in

Offline anthonydevanney

  • *
  • Posts: 11
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 2002 1.9 tdi zetec
  • Region: Yorkshire
Re: galaxy mk2
« Reply #4 on: January 30, 2016, 09:58:19 PM »
Heating wasnt working before i used the k seal pal

Offline anthonydevanney

  • *
  • Posts: 11
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 2002 1.9 tdi zetec
  • Region: Yorkshire
Re: galaxy mk2
« Reply #5 on: January 30, 2016, 09:58:40 PM »
Thank you

Offline johnnyroper

  • *
  • Posts: 2982
  • Thanked: 150
  • Model: Galaxy Mk2
  • Spec: 02 tdi 115 ghia
  • Region: South West
  • Country: United Kingdom
Re: galaxy mk2
« Reply #6 on: January 30, 2016, 10:30:40 PM »
Could well be air locked give pipe a check first and see if clear.

The plug is for the radio aerial,it's from amplifier to window aerial.

Offline anthonydevanney

  • *
  • Posts: 11
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 2002 1.9 tdi zetec
  • Region: Yorkshire
Re: galaxy mk2
« Reply #7 on: January 30, 2016, 10:35:49 PM »
Thanks

 

Advertisement:


SMF spam blocked by CleanTalk