Welcome, Guest. Please login or register.
Did you miss your activation email?
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

We Support:


Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy / VW Sharan / SEAT Alhambra Forum:

Author Topic: Handbreak display light problem  (Read 2308 times)

Offline safazaurs

  • *
  • Posts: 1
  • Thanked: 0
  • Model: Galaxy Mk1
  • Spec: 1999, 2.3i DOHC
Handbreak display light problem
« on: June 27, 2012, 08:50:59 PM »
Hello.
In the beginning I want to say sorry for my English.
So, I have Ford Galaxy 2.3i 1999 DOHC (engine type Y5B). There is a problem with handbreak display light, it's working all the time, all the time annoying with that red light. I tried to disconnect switch which is near to handbreak, but the light still worked. In theory the light should be in the hidden state, because it should work when I'm making signal, which is, when I pull the handbreak, but if the switch is disconnect, then it means - there is no signal. Other thing what I tried, I cleaned that cork where the oil has been filled, because it could show the, for example, low level breaking oil.
I tried more or less everything what came up in my mind. Is there any other solutions, is there anybody else with this kind of problem?
It would be nice, if someone has technical manual for display, then i can "call" everything from display circuit and find an error.

And other problem is overheating, in the summer it reaches critical zone and all the time fan is working... I read something about it, like there is no space for changing air flows, like on the top there is hood with thermoisolation and at the bottom there is a pan.

Best regards,
Toms

Offline philclemo

  • *
  • Posts: 28
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 03 2.3 Zetec
Re: Handbreak display light problem
« Reply #1 on: July 05, 2012, 04:34:48 PM »
For the brake light problem, could the pads on the rear be worn? On some models there is a sensor in the pad which switches the light on the dash. Our Galaxy doesn't have this sensor, I know this because I have just replaced the rear discs and pads but when I was ordering them i was asked the question.

As for the overheating, I haven't heard of the airflow theory. There are two temperature sensors, one for the dash and one for the ECU. As far as I understand, the one for the ECU controls the mixture and the fans. The other simply displays the temp for you, the driver. So it would appear they are both working as the display and the fans are responding.

Perhaps it is the thermostat? I take it from the year, this is a mark2 Galaxy? If so the thermostat is quite different from the mark 1. On the mk2 it is fitted inline in the pipework and not housed on the cylinder head. The difference in cost is alarming though, approx 4-5 GBP for the mk 1 version from any motor factors to 35 GBP for the mk2 from Ford! There isn't a way of testing the mk 2 version either I don't think!

 

Advertisement:


SMF spam blocked by CleanTalk