Welcome, Guest. Please login or register.
Did you miss your activation email?
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy / VW Sharan / SEAT Alhambra Forum:

Author Topic: Heated Windscreen only working passenger side  (Read 6038 times)

Offline gordy41

  • *
  • Posts: 10
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 1.9 tdi
  • Region: North West
Heated Windscreen only working passenger side
« on: December 29, 2014, 10:32:03 AM »
Hi can anybody help please at title only passenger side of screen is working , does anybody have an idiots guide on what to check and where thanks in advance

Offline insanitybeard

  • Greetings from Mr Chick!
  • *
  • Posts: 2427
  • Thanked: 71
  • Model: Galaxy Mk2
  • Spec: '54 130ps TDI Ghia
  • First Name: Paul
  • Region: South West
  • Country: United Kingdom
Re: Heated Windscreen only working passenger side
« Reply #1 on: December 29, 2014, 11:14:13 AM »
Sorry to be the bearer of bad news but normally if a heated front screen is only working on one side then the screen itself requires replacement- the screen has two power feeds (via a 'ribbon' type flexible cable), one for the passenger side half heating elements and the other for the driver's side half, you could check to see if the cable is damaged and double check the connector is clean and properly fitted but if one side is working then 9 times out of 10 it's a new front screen I'm afraid.
Always learning..... Often by mistakes!

Offline gordy41

  • *
  • Posts: 10
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 1.9 tdi
  • Region: North West
Re: Heated Windscreen only working passenger side
« Reply #2 on: December 29, 2014, 11:20:14 AM »
thanks for reply , I did replace the panel filter a month ago and im now wondering if ive disturbed something try to get wiper linkage out of the way as it was a right pain in a**e

Offline insanitybeard

  • Greetings from Mr Chick!
  • *
  • Posts: 2427
  • Thanked: 71
  • Model: Galaxy Mk2
  • Spec: '54 130ps TDI Ghia
  • First Name: Paul
  • Region: South West
  • Country: United Kingdom
Re: Heated Windscreen only working passenger side
« Reply #3 on: December 29, 2014, 11:49:29 AM »
I can't recall where the connector/ ribbon cable emerges from the screen on the Mk2 Galaxy to say whether you may have accidentally disturbed it when removing the wiper linkage. The supply cable is fairly hefty because the heating elements in the screen use a lot of power.
Always learning..... Often by mistakes!

Offline gordy41

  • *
  • Posts: 10
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 1.9 tdi
  • Region: North West
Re: Heated Windscreen only working passenger side
« Reply #4 on: December 29, 2014, 11:52:22 AM »
It was working a while back and only really noticed with the frosted up windscreen these last few days , so it could well be me disturbing something , I will have a quick look when I get chance , thanks for replies

Offline Orbis

  • *
  • Posts: 76
  • Thanked: 3
  • Model: Galaxy Mk1
  • Spec: 1999 2.3 DOHC Ghia
  • Region: Non UK
  • Country: Belgium
Re: Heated Windscreen only working passenger side
« Reply #5 on: December 29, 2014, 01:30:35 PM »
I have the same problem on my MK2 at the right side of the windscreen (side of the engine). It's not half the windscreen but a zone about 30-35cm. Would this problem also be the windscreen or maybe a bad connection?

Offline gregers

  • *
  • Posts: 1711
  • Thanked: 12
  • Model: Transporter
  • Spec: vw t28 camper
  • First Name: greg
  • Region: East Midlands
  • Country: United Kingdom
Re: Heated Windscreen only working passenger side
« Reply #6 on: December 29, 2014, 09:32:23 PM »
as they get older they do tend to fail,on my smax its like a bar code  :(
vw t5 camper van.
reality is for people with no imagination
rip dad 21/12/10
rip mum 3/5/16
rip bruv 11/5/17
The FordMPV.com Forum - The free forum for questions and answers relating to the Ford Galaxy, S-Max and C-Max

Offline insanitybeard

  • Greetings from Mr Chick!
  • *
  • Posts: 2427
  • Thanked: 71
  • Model: Galaxy Mk2
  • Spec: '54 130ps TDI Ghia
  • First Name: Paul
  • Region: South West
  • Country: United Kingdom
Re: Heated Windscreen only working passenger side
« Reply #7 on: December 30, 2014, 12:08:05 PM »
I have the same problem on my MK2 at the right side of the windscreen (side of the engine). It's not half the windscreen but a zone about 30-35cm. Would this problem also be the windscreen or maybe a bad connection?

If it's a particular zone or group of elements that's not working then it's certainly an internal fault (burnt out element/connection) within the screen, as the elements are within the glass no repairs are possible, it'll be a replacement screen to rectify- get a large stonechip which causes a crack to appear in the screen so that it needs replacement (i.e- non repairable)- then you can get it sorted for your windscreen excess of 50 if you've got that cover!  ;)
Always learning..... Often by mistakes!

Offline Orbis

  • *
  • Posts: 76
  • Thanked: 3
  • Model: Galaxy Mk1
  • Spec: 1999 2.3 DOHC Ghia
  • Region: Non UK
  • Country: Belgium
Re: Heated Windscreen only working passenger side
« Reply #8 on: December 30, 2014, 12:39:27 PM »
If it's a particular zone or group of elements that's not working then it's certainly an internal fault (burnt out element/connection) within the screen, as the elements are within the glass no repairs are possible, it'll be a replacement screen to rectify- get a large stonechip which causes a crack to appear in the screen so that it needs replacement (i.e- non repairable)- then you can get it sorted for your windscreen excess of 50 if you've got that cover!  ;)
Haha, good idea. I'll have to check that ;). At the moment I'm still ok with it, but the zone doesn't have to become bigger.

It's strange that it fails on my MK2. My MK1 is of course older and I've used it's heated windscreen many more times I think, on winter holidays. That one is still fully working.

 

Related Topics

  Subject / Started by Replies Latest
9 Replies
8398 Views
Latest August 21, 2012, 09:22:05 PM
by blue metal
5 Replies
3764 Views
Latest May 14, 2013, 05:23:11 PM
by Mirez
22 Replies
9230 Views
Latest February 12, 2015, 09:03:06 PM
by gregers
12 Replies
10025 Views
Latest October 14, 2015, 11:07:14 AM
by mike wilson
2 Replies
2282 Views
Latest November 20, 2015, 06:28:17 PM
by marinabrid
1 Replies
1725 Views
Latest September 07, 2016, 01:23:44 PM
by johnnyroper

Advertisement:


SMF spam blocked by CleanTalk