Welcome, Guest. Please login or register.
Did you miss your activation email?
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy / VW Sharan / SEAT Alhambra Forum:

Author Topic: Heater Control Panel and Clock  (Read 3975 times)

Offline benny-z

  • *
  • Posts: 2
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 03 WGR GALAXY
  • Region: Non UK
Heater Control Panel and Clock
« on: March 30, 2015, 12:54:57 PM »
Hello

This is a 2002 Ford galaxy MK II. The heater control panel and some other things have stopped working. The Ac button, rear heater main switch, air re circulate switch, blow direction and temperature control buttons or knobs do not work. Only the fan speed control works.
Even the clock stopped working, as ESP indicate faulty with error code: 00778 for (steering angle sensor), the reader says" No Power to ESP ... ". The lights on the panel do not work either.
I've checked all the fuses, tailgate cables, the " reset tips", cleaned the connections behind the control panel , etc etc nothing works.
 
I know this problem have been on the forum before without any solution. I hope someone can help me to solve this issue now it seems to be a common problem.

CheerZ

Offline Chrispb

  • Mindsaysyesbodysaysnono
  • *
  • Posts: 3024
  • Thanked: 112
  • Model: Galaxy Mk2 Auto
  • Spec: 52reg TDI 115 Ghia
  • First Name: Chris
  • Region: South East
  • Country: United Kingdom
Re: Heater Control Panel and Clock
« Reply #1 on: March 30, 2015, 01:30:33 PM »
Hello and  welcome5
Have another look at fuse 32 if that is definitely OK then I would look at splice joint 32, see details Here
2009 Kia Sedona GS In Black 2.9CRDI 183PS. 5 Speed Manual WAV.
2003 MK2 Galaxy Ghia In Solid Black 1.9 TDI 115PS. 5 Speed Automatic.

Upgraded Eberspächer booster heater  to independent heating with 7 day timer.

With VCDS lite (full version) need a code clearing or want to scan for faults in the north kent area, PM me.
All for a pint of Strongbow.

The FordMPV.com Forum - The free forum for questions and answers relating to the Ford Galaxy, S-Max and C-Max

Offline daddyfixit

  • fixer of broken things
  • *
  • Posts: 106
  • Thanked: 7
  • Model: Galaxy Mk2
  • Spec: bog standard 90hp
  • Region: North West
  • Country: United Kingdom
Re: Heater Control Panel and Clock
« Reply #2 on: March 30, 2015, 07:07:29 PM »
1. keys out of ignition

take the knobs/front panel off and remove 4 torx screws, pull unit from the dash and unplug both multi plugs.

2. turn ign on for a few seconds then off again---take keys out

refit both multiplugs and refit to dashboard.

3. see if you were able to reset it by seeing if it all works !!

Offline benny-z

  • *
  • Posts: 2
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 03 WGR GALAXY
  • Region: Non UK
Re: Heater Control Panel and Clock
« Reply #3 on: April 05, 2015, 08:53:43 PM »
Hello and thanks for the tips.
I followed the splice joint 32 tips and re-soldered the joint, Indeed the entire cable kit was wet.
I also tried Daddyfixit tips. Unfortunately neither have solved the problem. 

Maybe it's a relay problem?! but which relay?

//BZ

Offline Chrispb

  • Mindsaysyesbodysaysnono
  • *
  • Posts: 3024
  • Thanked: 112
  • Model: Galaxy Mk2 Auto
  • Spec: 52reg TDI 115 Ghia
  • First Name: Chris
  • Region: South East
  • Country: United Kingdom
Re: Heater Control Panel and Clock
« Reply #4 on: April 06, 2015, 05:52:51 AM »
Can you just confirm there is no power going to the clock? there is another splice joint (S43) on the drivers side on the floor by the B pillar, this is by drivers lower seat belt mounting same colour wires red/white.
Can you also check for 12 volts at both 32 & 43.
2009 Kia Sedona GS In Black 2.9CRDI 183PS. 5 Speed Manual WAV.
2003 MK2 Galaxy Ghia In Solid Black 1.9 TDI 115PS. 5 Speed Automatic.

Upgraded Eberspächer booster heater  to independent heating with 7 day timer.

With VCDS lite (full version) need a code clearing or want to scan for faults in the north kent area, PM me.
All for a pint of Strongbow.

The FordMPV.com Forum - The free forum for questions and answers relating to the Ford Galaxy, S-Max and C-Max

 

Related Topics

  Subject / Started by Replies Latest
9 Replies
9663 Views
Latest June 25, 2013, 11:21:17 PM
by Grant2012
2 Replies
2544 Views
Latest April 22, 2014, 05:47:40 PM
by Mirez
2 Replies
2838 Views
Latest April 27, 2014, 09:39:48 PM
by Chrispb
5 Replies
1934 Views
Latest November 18, 2016, 05:58:11 PM
by johnnyroper
35 Replies
2035 Views
Latest October 11, 2018, 07:41:59 PM
by brianh
21 Replies
1064 Views
Latest December 07, 2018, 10:14:41 PM
by johnnyroper

Advertisement:


SMF spam blocked by CleanTalk