Ford and Volkswagen MPV Forums

Large MPVs -- Ford Galaxy / VW Sharan / SEAT Alhambra: => Ford Galaxy / VW Sharan / SEAT Alhambra => Topic started by: martinrichard on February 03, 2017, 10:25:57 PM

Title: Indicator and Hazard warning light problem
Post by: martinrichard on February 03, 2017, 10:25:57 PM
I've been replacing a faulty cylinder head gasket and all has gone well except this last bit of snagging.
It is such a specific subject that I thought I should start a new thread for future reference, rather than have any help lost in my previous cylinder head thread. So here goes:

The hazard lights work (all 6 - 2 front 2 back 2 side) when the switch is depressed.

With Ignition off
Indicator position;
Left     - beep only
Centre - nothing ( no light no beep)
Right   - all lights flash at normal rate, but all 6, like hazard warning and there is a beep

With Ignition on
Indicator position;
Left      -  left direction indicators flash at normal speed
Centre  -  left direction indicators flash at normal speed (but shouldn't of course)
Right    -  all lights flash at normal rate but all 6 (like hazard warning)

Some background - this has stood idle for a month while I changed the cylinder head gasket.
I then tried jump starting it from an external battery with the leads the wrong way around.
Blew the purple 3 Amp fuse in the battery/auxillary fuse box, now fixed (thanks Chrispb)

If anything, I think that the hazard switch may be a bit stickier than it was.
Am thinking that step one is to remove it and clean it up.
Can anybody shine a light on things?
Cheers
Martin
Title: Re: Indicator and Hazard warning light problem
Post by: martinrichard on February 03, 2017, 11:00:29 PM
More briefly:

The hazard lights come on when I indicate!
Title: Re: Indicator and Hazard warning light problem
Post by: johnnyroper on February 04, 2017, 06:09:52 AM
With any electrical glitch on these cars it's always worth having a check of the wiring from car to doors and tailgate as they are prone to breaking and shorting across circuits.

And as above the hazard switch also needs to be checked out.
Title: Re: Indicator and Hazard warning light problem
Post by: martinrichard on February 04, 2017, 03:54:25 PM
Hi johnnyroper
I just looked at how to remove the hazard warning switch.
Took out the dummy below it and tried to push it out from behind.
It didn't budge on this first attempt, however when I checked the indicators after this step they worked normally!
Then used the hazard switch and they went wrong.
Repeated Step 1 (fiddle with hazard switch) and the indicators worked again.
So looks like I have to understand how to push out the hazard warning switch and replace it (or dry it out / clean it up perhaps)
Thank you again!