Welcome, Guest. Please login or register.
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

Advertisement:


Recent Forum Topics:

Google Translate:

Ford Galaxy / VW Sharan / SEAT Alhambra Forum:

Author Topic: lack of power tdi 115 gal.  (Read 2730 times)

Offline twinkle

  • *
  • Posts: 8
  • Thanked: 0
  • Model: Other
  • Spec: mondeo Zetec S
lack of power tdi 115 gal.
« on: May 30, 2014, 07:49:58 PM »
Im having a nightmare problem on my 115 tdi galaxy.

its down on power. I have read on the net about all sorts of problems that can cause this, but this seems odd on mine.

on first start up, I have almost no power until I get it to 3k rpm, then something kicks in and I have some power back. After this happens, I have this half power thro all gears, untill I switch it off, and its back to square one.
the turbo spins as you can hear it, have checked hoses, and cant see any split as off yet.
my mate plugged it in the computer,  and nothing electrical showed up like over boost / under boost.

Before I strip the whole engine to check the hoses again any ideas? Not sure where this n75 boost relay is either?

Really appreciate any help on this. Cheers :)

Offline insanitybeard

  • Greetings from Mr Chick!
  • *
  • Posts: 2383
  • Thanked: 70
  • Model: Galaxy Mk2
  • Spec: '54 130ps TDI Ghia
  • First Name: Paul
  • Region: South West
  • Country: United Kingdom
Re: lack of power tdi 115 gal.
« Reply #1 on: May 31, 2014, 12:09:41 AM »
From your description I would say it's got a chance of having the (fairly common) stuck turbo vane mechanism- the variable geometry turbos fitted on the Galaxies (apart from the 90ps TDI) can carbon up and seize, usually if the vehicle does lots of round town start stop driving. To check, get underneath the car and try to manually operate the linkage rod that goes from the vacuum actuator on the turbo (the silver coloured cylindrical canister that sits on the side of the turbo unit) into the turbine wheel housing, where the variable vane mechanism is located. If you can't move it- chances are it's seized, therefore you're only getting optimum boost at certain revs. For more info see this.
Always learning..... Often by mistakes!

Offline twinkle

  • *
  • Posts: 8
  • Thanked: 0
  • Model: Other
  • Spec: mondeo Zetec S
Re: lack of power tdi 115 gal.
« Reply #2 on: May 31, 2014, 08:43:54 AM »
Will have a look. See if it moves. Cheers   :)

Offline twinkle

  • *
  • Posts: 8
  • Thanked: 0
  • Model: Other
  • Spec: mondeo Zetec S
Re: lack of power tdi 115 gal.
« Reply #3 on: May 31, 2014, 07:50:28 PM »
Been trying the n75 solenoid today, took the pipe off going to the accuator, theres a good vacuum suck, took the plug off it, and no suck, so take it, the solenoid is opening and closing ok.

tryed to get to accuator, but only have a jack, and didnt fancy being right under car like this, so will have to get some axle stands I think.

other thing I noticed, when driving with the n75 un plugged, the engine is totally gutless, but plugged in, it defo has more power. Also noticed, with foot hard down at low revs, and then let off, thats defo alot of chatter which never really noticed before.

Offline Ricardo Martins

  • *
  • Posts: 10
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 1.9 TDi 115HP
  • First Name: Ricardo
  • Region: Non UK
  • Country: Portugal
Re: lack of power tdi 115 gal.
« Reply #4 on: August 17, 2017, 10:06:42 PM »
@twinkle any news about the problem?

Offline Kristaps Baltais

  • *
  • Posts: 76
  • Thanked: 3
  • Model: Sharan Mk2
  • Spec: 04 1.9tdi 115hp
  • Region: Non UK
  • Country: Norway
Re: lack of power tdi 115 gal.
« Reply #5 on: August 18, 2017, 10:34:32 AM »
check all vacum tubes, they tend to split .
Buying this car after knowing all common problems feels bit sadistic, but then again, my main income is from growing potatoes in arctic.

 

Related Topics

  Subject / Started by Replies Latest
9 Replies
8355 Views
Latest June 24, 2012, 04:41:26 PM
by lavill78
4 Replies
2424 Views
Latest December 20, 2013, 02:37:19 PM
by alhajasif
8 Replies
6454 Views
Latest June 16, 2019, 05:30:32 PM
by brianh
29 Replies
9299 Views
Latest July 14, 2014, 09:56:54 AM
by julieade
6 Replies
3123 Views
Latest October 17, 2014, 09:43:47 PM
by gregers
7 Replies
2918 Views
Latest December 08, 2015, 08:51:45 AM
by johnnyroper

Advertisement: