Ford and Volkswagen MPV Forums

Large MPVs -- Ford Galaxy / VW Sharan / SEAT Alhambra: => Ford Galaxy / VW Sharan / SEAT Alhambra => Topic started by: ccberowles on May 09, 2013, 02:40:07 PM

Title: Loss of power
Post by: ccberowles on May 09, 2013, 02:40:07 PM
Can anyone shed any light on this for me? I have a MK2 Galaxy Ghia Tdi130 and I get an occasional loss of power. The engine will only rev to about 2000rpm and if I am on the motorway for example it wil only do about 70mph. If I pull over, switch it off then start again all is fine! Apart from this it runs fine for the rest of the time.
Any one got an idea?
Title: Re: Loss of power
Post by: Chrispb on May 09, 2013, 03:17:39 PM
Sounds like you have a classic boost issue, under or overboost the latter being the popular.

VCDS lite will confirm which, overboost most of the time is due to sticky turbo vanes especially if you do a lot of town stop and start driving.

There is a cleaner you can use (Innotec) but does require some dismantling.

Or you can try the Italian tune up

Last resort is to remove turbo and clean manually

You can also use the search box this will bring up other posts and info that will be of help or just ask.
Title: Re: Loss of power
Post by: ccberowles on May 09, 2013, 05:00:11 PM
Thanks for this, much obliged. It seems this is quite common now I have perused the site!
Title: Re: Loss of power
Post by: ccberowles on May 09, 2013, 05:06:22 PM
Out of interest would it be likey to smoke profusely if over boosting? I only ask cos mine doesn't seem to smoke at all during these episodes...
Are there any other symptoms?
I like the idea of the Italian tune up  ;D
Title: Re: Loss of power
Post by: Chrispb on May 09, 2013, 06:56:48 PM
No there won't be any extra smoke.