Ford and Volkswagen MPV Forums

Large MPVs -- Ford Galaxy / VW Sharan / SEAT Alhambra: => Ford Galaxy / VW Sharan / SEAT Alhambra => Topic started by: nkswinburne on July 03, 2013, 07:12:27 PM

Title: MAF Galaxy 2001 2.8 v6 auto
Post by: nkswinburne on July 03, 2013, 07:12:27 PM
Hi my 2001 galaxy 2.8 v6 auto has developed a problem after it has warmed up on long journey, It feels under powered and epc light comes on and it enters limp home mode.The fault reads mass air flow implausible signal I have replaced the MAF but it has had no effect still getting the same problem if anything the new MAF made it worse. I also seem to have a misfire at around 1500 rpm and a delay when I press the throttle followed but a sucking noise like its gasping for breath Was hoping some one on here might be able to point me in the right direction as to what could be the cause of this as its driving me nuts.
 
Could the misfire be causing the implausible signal error? 
Title: Re: MAF Galaxy 2001 2.8 v6 auto
Post by: Mirez on July 03, 2013, 11:43:36 PM
The MAF might be ared herring tbh as the EPC light is the electronic power control system amd thats normally your throttle body and accelerator pedal although the MAF is part of the circuit. Certainly an iffy TB can cause all manor of weird and wonderfull faults, when I had the V6 it had zero power, spluttered and felt like misfires yet nothing in VCDS. Did you clear the fault code after replacing and have you acanned again since?
Title: Re: MAF Galaxy 2001 2.8 v6 auto
Post by: nkswinburne on July 04, 2013, 01:38:15 AM
Hi!! yes I erased all the codes and every time EPC comes back on and it's the same fault Mass air flow implausible signal.
Title: Re: MAF Galaxy 2001 2.8 v6 auto
Post by: Mirez on July 04, 2013, 10:37:20 AM
Ok, did you double check the part numbers from the old MAF and the new MAF? The V6 uses a different MAF entirely to the TDI but a lot of online sellers just list one "Galaxy MAF"!

If you did then you'll need to start looking at the wiring to/from the MAF.

Also, using VCDS, In measuring blocks for the ECU what are the MAF values reading?
Title: Re: MAF Galaxy 2001 2.8 v6 auto
Post by: nkswinburne on July 04, 2013, 02:14:23 PM
Ok guess I'd better get the gloves on looks like I'm I'm for a long journey with this one.
Title: Re: MAF Galaxy 2001 2.8 v6 auto
Post by: Chrispb on July 04, 2013, 02:41:08 PM
Have seen references to faulty wiring close to the MAF multiplug, hopefully yours is just the wrong MAF.
Was it a genuine part usually Bosch or Pierburg not one of those cheap ebay ones? they tend to give more problems than the original as I found out.
Title: Re: MAF Galaxy 2001 2.8 v6 auto
Post by: nkswinburne on July 05, 2013, 06:56:47 AM
It was a genuine part. The MAF is working but the car has no guts at all now.
Title: Re: MAF Galaxy 2001 2.8 v6 auto
Post by: Mirez on July 05, 2013, 05:43:25 PM
But is it the right MAF... there are around 12 different variants and the correct part number is critical!
Title: Re: MAF Galaxy 2001 2.8 v6 auto
Post by: nkswinburne on July 06, 2013, 04:52:42 PM
Hi guys yes part number matched the one I took off.I talked to an ex vw mechanic who suggested it might be the temp sensor to the ECU as they had problems with them in the past. Getting the car put on a laptop on Monday to check the live data to see what it's telling the car