Ford and Volkswagen MPV Forums

Large MPVs -- Ford Galaxy / VW Sharan / SEAT Alhambra: => Ford Galaxy / VW Sharan / SEAT Alhambra => Topic started by: steenL on June 05, 2017, 03:38:11 PM

Title: Missing power for clock and HVAC
Post by: steenL on June 05, 2017, 03:38:11 PM
Ford Galaxy MkII 2003.
My clock and HVAC has no power from fuse F32. There is power on red/white wire just after fuse (Fuse OK). But no power at the usage points for the clock and HVAC.
According to Haynes - Ford Galaxy, the F32 is distributed for central locking system (fully functioning) and other stuff.
So, how to proceed?
 -Any chance to find some distribution point for the red/white wire, and improve connection?
 -Should i just add a direct connection wire (I tried this temporarily, it works)?
 -I have an ELM 327 OBDII wifi interface. Is this of any use finding/correcting the error? What software should I use?
Any help greatly appreciated!
Title: Re: Missing power for clock and HVAC
Post by: Mirez on June 05, 2017, 04:21:20 PM
F32 has a couple of distrubution points, one of them being at the bottom of the passenger side A pillar (bit of a pig to find) and the other is by the drivers footwell. Both are known corrosion spots...

32, Brown, 5amp
ESP, Cruise Control, Auxiliary Heater, A/C, Instrument Cluster, Clock, Radio, RSE, Modular network (K-Line), OBD Port, Alarm, PATS, Satellite Navigation, Telephone System, Headlight Washer Control, Electric Window Memory, Central Door Locking, Steering Position Sensor


Since some of those circuits are also the fuse is intact then I would be happy to say your issues is one of those joints. If you can find them, you can repair but running another wire is acceptable if not.
Title: Re: Missing power for clock and HVAC
Post by: johnnyroper on June 05, 2017, 07:36:29 PM
There's a how to here for checking the pax side one.

https://www.fordmpv.com/smf2/ford-galaxy-reference-library/splice-joint-32/msg7309/#msg7309/