Welcome, Guest. Please login or register.
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

Advertisement:


Recent Forum Topics:

Google Translate:

Ford Galaxy / VW Sharan / SEAT Alhambra Forum:

Author Topic: Mk2 front blower no power  (Read 188 times)

Offline Geduk

  • *
  • Posts: 53
  • Thanked: 0
  • Model: Galaxy Mk2 Auto
  • Spec: 03 1.9 tdi auto 11
  • Region: West Midlands
Mk2 front blower no power
« on: December 15, 2019, 06:15:41 AM »
Hi all my front blower has no power can anyone confirm what relay is powering the blower I have checked the blower is work and changed the frog from the back to the front still with no joy can the relay be repaired is it worth it or just get a new relay?

Offline brianh

  • *
  • Posts: 665
  • Thanked: 61
  • Model: Galaxy Mk2
  • Spec: 2001 2.3 Ghia LPG
  • First Name: Brian
  • Region: South East
  • Country: United Kingdom
Re: Mk2 front blower no power
« Reply #1 on: December 15, 2019, 05:04:50 PM »
Does yours have a climate control panel (all buttons with an LCD display) or 3 dials to direct air and set fan speed/temperature?

Define dead - does the motor not run, or is the display completely dead and you can't get it to do anything?

The usual suspect is the heater resistor pack for the kind of fault you mention.

Offline Geduk

  • *
  • Posts: 53
  • Thanked: 0
  • Model: Galaxy Mk2 Auto
  • Spec: 03 1.9 tdi auto 11
  • Region: West Midlands
Re: Mk2 front blower no power
« Reply #2 on: December 16, 2019, 02:44:20 PM »
It's dials and no 12v at the plug I've swaped the resisted packs made no difference

Offline brianh

  • *
  • Posts: 665
  • Thanked: 61
  • Model: Galaxy Mk2
  • Spec: 2001 2.3 Ghia LPG
  • First Name: Brian
  • Region: South East
  • Country: United Kingdom
Re: Mk2 front blower no power
« Reply #3 on: December 16, 2019, 06:50:17 PM »
I think you may need to look at the services 32  splice joint in the passenger side footwell. Basically a bunch of red cables twisted together. If its flooded (which due to blocked scuttle drains or a leaking rear washer pipe is likely to have happened at some point) the joint can get corroded or broken. Rejoining and soldering joint should rule that out being a problem. You should be able to access it by removing the inner door trim on that side.

Further info > https://www.fordmpv.com/smf2/ford-galaxy-common-faults-and-problems/splice-joint-32/msg7309/#msg7309

Offline brianh

  • *
  • Posts: 665
  • Thanked: 61
  • Model: Galaxy Mk2
  • Spec: 2001 2.3 Ghia LPG
  • First Name: Brian
  • Region: South East
  • Country: United Kingdom
Re: Mk2 front blower no power
« Reply #4 on: December 16, 2019, 07:19:18 PM »
This may help, sorry about the formatting though!

 

Related Topics

  Subject / Started by Replies Latest
12 Replies
4985 Views
Latest November 24, 2013, 09:40:25 PM
by SilverBeast
4 Replies
3669 Views
Latest April 29, 2015, 08:20:34 PM
by robs car
4 Replies
2959 Views
Latest September 19, 2015, 06:39:20 PM
by poorcol1964
0 Replies
718 Views
Latest June 26, 2018, 09:32:41 PM
by Roly69
0 Replies
741 Views
Latest July 04, 2018, 05:08:06 PM
by Roly69
2 Replies
559 Views
Latest September 21, 2019, 08:24:04 AM
by SirDavidAlhambra

Advertisement: