Welcome, Guest. Please login or register.
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

Advertisement:


Recent Forum Topics:

Google Translate:

Ford Galaxy / VW Sharan / SEAT Alhambra Forum:

Author Topic: new user.....power loss issues mk2 tdi  (Read 495 times)

Offline scottda

  • *
  • Posts: 1
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 02 tdi 115 zetec
  • First Name: darren
  • Region: Scotland
new user.....power loss issues mk2 tdi
« on: July 12, 2019, 09:49:55 AM »
guys can anyone shed some light on an issue I am having...

I have a ford galaxy mk2 2002 1.9 tdi 115 zetec...

it I very sluggish and unresponsive up till around 2k revs and then it takes of.also cruising around 70 it has started losing power. turning the ignition of then on resolves the power loss issue at speed but obviously is not the fix. are these two separate issues or can they be related? there is no black smoking or roughness and the turbo does seem to kick in but only after 2k revs. the car has been well serviced also. any help would be appreciated? I am based in fife. would It be an idea to find someone with vagcom to run a diagnostics/live data?

Offline johnnyroper

  • *
  • Posts: 2693
  • Thanked: 125
  • Model: Galaxy Mk2
  • Spec: 02 tdi 115 ghia
  • Region: South West
  • Country: United Kingdom
Re: new user.....power loss issues mk2 tdi
« Reply #1 on: July 12, 2019, 09:53:52 AM »
Sounds like it is suffering with turbo vanes sticking to me.
You need to try and get to the actuator on turbo and see if it is moving freely itís entire length of travel. Also check vac pipes for splits etc.
Checking with vcds is a good start aswell as it will give an indication of whatís wrong I would suspect it has a boost deviation fault logged

Offline SirDavidAlhambra

  • Sir David Alhambra.
  • *
  • Posts: 353
  • Thanked: 3
  • Model: Alhambra Mk2 Auto
  • Spec: 2006 1.9 Tdi auto
  • First Name: Dave
  • Region: South East
  • Country: United Kingdom
Re: new user.....power loss issues mk2 tdi
« Reply #2 on: July 13, 2019, 01:47:08 PM »
Yes, mr roper is probably right, my first place to look would be the turbo charger.

Now, a word of advice. Reconditioned turbos are not worth the hassle in my opinion and in my experience the companies often try and blame your car when it doesnít work because of a defect. Pay a little extra and get a proper one from the manufacturer is my suggestion. Yes it costs a little more but I know so many people that have wasted hours on the phone arguing with reconditioned turbo sellers giving them the run around. Not to mention the hassle and cost of having to fit a turbo twice. Did you know that the manufacturer doesnít publish the specifications? Always do the job properly.

I hope you are able to get this worrying problem fixed soon. One day I hope cars will be free of this problem
I drive a Seat Alhambra 1.9Tdi which has 115bhp and an automatic gearbox.

I am happy to help you with all your questions. I am not a qualified mechanic but seem to be better at fixing my car than even the most experienced garages.

I have lots of friends here and very much enjoy talking with you all.

Always remember, a motor car is a serious tool and should be treated with respect. Put your safety first, always.

Offline bigjeeze

  • *
  • Posts: 307
  • Thanked: 2
  • Model: Galaxy Mk2 Auto
  • Spec: 03 Tdi Ghia Auto
  • Region: South West
  • Country: United Kingdom
Re: new user.....power loss issues mk2 tdi
« Reply #3 on: July 21, 2019, 11:28:24 AM »
Err... perhaps this is not the forum to be selling on!  reconditioned parts can be perfectly fine. What you should concentrate on is a correct diagnosis. A turbo is a piece of machinery that if properly set up will do it's job - provided it's able.
On the Square

Offline johnnyroper

  • *
  • Posts: 2693
  • Thanked: 125
  • Model: Galaxy Mk2
  • Spec: 02 tdi 115 ghia
  • Region: South West
  • Country: United Kingdom
Re: new user.....power loss issues mk2 tdi
« Reply #4 on: July 21, 2019, 01:56:55 PM »
I agree I have fitted recon turbos in the past and found them to be perfectly fine so long as from a reputable supplier. I would hazard a guess at most main dealer supplied turbos are recon units aswell.

Offline SirDavidAlhambra

  • Sir David Alhambra.
  • *
  • Posts: 353
  • Thanked: 3
  • Model: Alhambra Mk2 Auto
  • Spec: 2006 1.9 Tdi auto
  • First Name: Dave
  • Region: South East
  • Country: United Kingdom
Re: new user.....power loss issues mk2 tdi
« Reply #5 on: July 21, 2019, 07:43:34 PM »
The man at the turbo shop said the manufacturers donít publish the calibration settings for the turbos though and that the reconditioned ones are never quite as good. He was really convincing and said that sometimes they donít set them up right and if U have a problem they often blame your car and stuff because they have more technical expertise than u and are more experienced at fobbing off etc.

It sounded really convincing so I bought a new one, also I saw loads of bad reviews on the internet.

That said I feel like the people here are my friends and for that reason I sincerely hope you all save money and have good experiences with your cars. There is a lot of expertise here and I am just one person so it is important we all share our experiences so we can all save money on our cars and make good choices
I drive a Seat Alhambra 1.9Tdi which has 115bhp and an automatic gearbox.

I am happy to help you with all your questions. I am not a qualified mechanic but seem to be better at fixing my car than even the most experienced garages.

I have lots of friends here and very much enjoy talking with you all.

Always remember, a motor car is a serious tool and should be treated with respect. Put your safety first, always.

Offline brianh

  • *
  • Posts: 617
  • Thanked: 61
  • Model: Galaxy Mk2
  • Spec: 2001 2.3 Ghia LPG
  • First Name: Brian
  • Region: South East
  • Country: United Kingdom
Re: new user.....power loss issues mk2 tdi
« Reply #6 on: July 21, 2019, 08:52:49 PM »
To be fair, sticking a recon or brand new turbo onto a used engine is never going to match the performance of the same turbo onto a new engine anyway. Plus if performance was really what you were after, your hardly likely to be using a Galaxy to get it (or at least you'd go for the 2.8 v6 engine one, though its still going to be a heavy beast to move about all the same).

A lot of the problems with the turbo's on these can be down to sticking actuators and such - and can be fixed with cleaning a lot of the time rather than replacement as many posts on here will tell you, and has been pointed out above in posts on this thread as well. Equally split hoses can cause issues, but once located are easy and cheap to fix, the problem is finding them.

The first step beyond having a look for anything obvious, is to check what VCDS shows if anything in the way of faults, its cheap enough to get hold of a cable off eBay or other places (the lite/free version will work with the cables available for less than a tenner, and the free version will show you most of the info you'd ever need).

Offline johnnyroper

  • *
  • Posts: 2693
  • Thanked: 125
  • Model: Galaxy Mk2
  • Spec: 02 tdi 115 ghia
  • Region: South West
  • Country: United Kingdom
Re: new user.....power loss issues mk2 tdi
« Reply #7 on: July 21, 2019, 10:05:50 PM »
I agree that recon units can arrive not quite set up right from certain places but a decent recon place will have the kit to set up the vane gap,stop screw position and balance correctly. The last one I bought came with a printout of the bench test from first test and from after they had balanced and tweaked it.
Also it is not too difficult to set one up in all honesty, my galaxy had a recon prior to me purchasing it and it was not quite right. I set the vane gap and then set actuator length using a vac pump and once in the car plotted some logs to fine tune it.

Essentially a vnt turbo works the same no matter what engine it goes on.

As Brian said most cases it is other issues on these cars that donít necessarily need a replacement turbo. Split vac hoses,n75, actuator diaphragm or sticky vanes

 

Related Topics

  Subject / Started by Replies Latest
4 Replies
3299 Views
Latest May 09, 2013, 06:56:48 PM
by Chrispb
6 Replies
3551 Views
Latest July 03, 2014, 12:24:56 AM
by julieade
1 Replies
1788 Views
Latest July 12, 2014, 01:10:29 PM
by Mirez
22 Replies
6351 Views
Latest September 26, 2014, 07:03:44 PM
by insanitybeard
3 Replies
2589 Views
Latest March 25, 2015, 03:28:03 PM
by Chrispb
4 Replies
3512 Views
Latest April 29, 2015, 08:20:34 PM
by robs car

Advertisement: