Welcome, Guest. Please login or register.
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy / VW Sharan / SEAT Alhambra Forum:

Author Topic: Newbie with speedo problems  (Read 3501 times)

Offline Scottyboy

  • *
  • Posts: 6
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 150 tdi
Newbie with speedo problems
« on: June 23, 2013, 05:38:25 PM »
Hi I'm new to this forum I have a 2001 ford galaxy tdi150 I have had the car a couple off weeks now when I bought the car the speedo was jammed at 65mph

I have vag com so I plugged it in and done a Dial test all dials worked Barr speedo it was jumping on the spot

Tool dials apart oiled up the speedo needle and worked it back and forward as it was tight now it moves freely

Dail test take 2 now all dials work when tested on vag com

Road test speedo still not working scanned with vag com and still has a g22 speedo fault

I have the dancing fuel gauge also I read some where that these are linked together 

Any ideas? Thanks scott

Offline Chrispb

  • Mindsaysyesbodysaysnono
  • *
  • Posts: 3001
  • Thanked: 102
  • Model: Galaxy Mk2 Auto
  • Spec: 52reg TDI 115 Ghia
  • First Name: Chris
  • Region: South East
  • Country: United Kingdom
Re: Newbie with speedo problems
« Reply #1 on: June 23, 2013, 08:06:46 PM »
IIRC vehicle speed sensor faulty or faulty connection to it.
Located on gearbox.
2009 Kia Sedona GS In Black 2.9CRDI 183PS. 5 Speed Manual WAV.
2003 MK2 Galaxy Ghia In Solid Black 1.9 TDI 115PS. 5 Speed Automatic.

Upgraded Eberspächer booster heater  to independent heating with 7 day timer.

With VCDS lite (full version) need a code clearing or want to scan for faults in the north kent area, PM me.
All for a pint of Strongbow.

The FordMPV.com Forum - The free forum for questions and answers relating to the Ford Galaxy, S-Max and C-Max

Offline Scottyboy

  • *
  • Posts: 6
  • Thanked: 0
  • Model: Galaxy Mk2
  • Spec: 150 tdi
Re: Newbie with speedo problems
« Reply #2 on: June 23, 2013, 09:59:01 PM »
Is there any way to test the sensor or just fire a new one on?

 

Related Topics

  Subject / Started by Replies Latest
2 Replies
2139 Views
Latest February 26, 2014, 08:44:06 AM
by delbwoy2003
3 Replies
2409 Views
Latest July 21, 2014, 05:01:51 PM
by Mirez
13 Replies
4913 Views
Latest December 14, 2014, 05:48:10 PM
by Mirez
1 Replies
1832 Views
Latest May 23, 2015, 09:10:05 PM
by gregers
2 Replies
4536 Views
Latest June 17, 2015, 06:04:45 PM
by insanitybeard
2 Replies
2042 Views
Latest March 30, 2016, 03:57:31 PM
by superwin

Advertisement: