Welcome, Guest. Please login or register.
Did you miss your activation email?
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

We Support:


Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy / VW Sharan / SEAT Alhambra Forum:

Author Topic: Power loss and revving up on start??  (Read 133 times)

Offline cbv8

  • *
  • Posts: 25
  • Thanked: 1
  • Model: Galaxy Mk2 Auto
  • Spec: 03 TDI Zetec auto
  • Region: East Midlands
  • Country: United Kingdom
Power loss and revving up on start??
« on: April 18, 2021, 05:41:36 PM »
Advice please all the knowledgables since fitting my egr plate to my 03 1.9 tdi auto i have notice when starting the car it revs up for a few secs then settles down also it now seems to lack power any ideas please  ;)
Cheers,
Chas.

Offline SirDavidAlhambra

  • Sir David Alhambra.
  • *
  • Posts: 757
  • Thanked: 19
  • Model: Alhambra Mk2 Auto
  • Spec: 2006 1.9 Tdi auto
  • First Name: Dave
  • Region: South East
  • Country: United Kingdom
Re: Power loss and revving up on start??
« Reply #1 on: April 18, 2021, 06:52:37 PM »
Recommend remove egr plate
I drive a Seat Alhambra 1.9Tdi which has 115bhp and an automatic gearbox.

I am happy to help you with all your questions. I am not a qualified mechanic but seem to be better at fixing my car than even the most experienced garages.

I have lots of friends here and very much enjoy talking with you all.

Always remember, a motor car is a serious tool and should be treated with respect. Put your safety first, always.

Offline cbv8

  • *
  • Posts: 25
  • Thanked: 1
  • Model: Galaxy Mk2 Auto
  • Spec: 03 TDI Zetec auto
  • Region: East Midlands
  • Country: United Kingdom
Re: Power loss and revving up on start??
« Reply #2 on: April 18, 2021, 07:10:57 PM »
Why may i ask i fitted one to my previous 05 Gal and was noticeably quicker and less sluggish why should this one be any different???
Cheers,
Chas.

Offline brianh

  • *
  • Posts: 1001
  • Thanked: 169
  • Model: Galaxy Mk2
  • Spec: 2001 2.3 Ghia LPG
  • First Name: Brian
  • Region: South East
  • Country: United Kingdom
Re: Power loss and revving up on start??
« Reply #3 on: April 18, 2021, 09:55:14 PM »
I'd wonder if you've disconnected one of the vacuum lines when fitting the valve, couple of suggestions - the obvious one being have a good look around to see if you can see anything amiss, the other would be to do a code scan and see if anything is shown.

Note that you may have disturbed something like a pipe that already had a hole in it from rubbing against something else and its only obvious now that there is a problem where you have moved stuff about.

It may also be worth trying with the MAF unplugged to see if the power loss persists, this may point towards a dodgy  MAF, others have posted this here as you've probabbly seen in the posts.

I don't know the TDI well enough to comment on the EGR blanking though others here will know it better, but the suggestion of removing it to see if the problem goes away given it appeared when you fitted it, would at least help narrow down if its the EGR blank thats doing it, or something else.

Offline cbv8

  • *
  • Posts: 25
  • Thanked: 1
  • Model: Galaxy Mk2 Auto
  • Spec: 03 TDI Zetec auto
  • Region: East Midlands
  • Country: United Kingdom
Re: Power loss and revving up on start??
« Reply #4 on: April 18, 2021, 10:10:36 PM »
Thanks for the suggestions much appreciated i will have a look tomorrow but as you can imagine viewing the rear of the engine components is very restricted  :-\
Cheers,
Chas.

Offline brianh

  • *
  • Posts: 1001
  • Thanked: 169
  • Model: Galaxy Mk2
  • Spec: 2001 2.3 Ghia LPG
  • First Name: Brian
  • Region: South East
  • Country: United Kingdom
Re: Power loss and revving up on start??
« Reply #5 on: April 18, 2021, 10:13:27 PM »
I can imagine so, taking the scuttle out might help, but also a torch with a mirror on a stick can be helpful if your looking at bits like that.

Something like this https://www.amazon.co.uk/Silverline-457053-Telescopic-Mirror-370/dp/B000WTNKEC/

Offline johnnyroper

  • *
  • Posts: 3147
  • Thanked: 162
  • Model: Galaxy Mk2
  • Spec: 02 tdi 115 ghia
  • Region: South West
  • Country: United Kingdom
Re: Power loss and revving up on start??
« Reply #6 on: April 19, 2021, 02:02:07 AM »
Advice please all the knowledgables since fitting my egr plate to my 03 1.9 tdi auto i have notice when starting the car it revs up for a few secs then settles down also it now seems to lack power any ideas please  ;)

Cant think of any obvious reason why blanking egr would cause that,I got rid of mine all together and went simplified vac hose set up and didnít suffer this problem.
And like you the car performed so much better without the egr fitted
Have you access to diagnostic software that has live data capabilities?

 

Advertisement:


SMF spam blocked by CleanTalk