Welcome, Guest. Please login or register.
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy / VW Sharan / SEAT Alhambra Forum:

Author Topic: Speedo and fuel gauge problems  (Read 4484 times)

Offline Bearhairs

  • *
  • Posts: 2
  • Thanked: 0
  • Model: Galaxy Mk1
  • Spec: 1900TDI
  • Region: South East
Speedo and fuel gauge problems
« on: June 16, 2015, 01:50:10 PM »
Hi,
Having sudden problem, both started at the same time.
Speedo not working and at the same time the fuel gauge keeps beeping and going from zero tp 1/4

Many thanks for help
« Last Edit: June 16, 2015, 01:56:26 PM by Bearhairs »

Offline Bearhairs

  • *
  • Posts: 2
  • Thanked: 0
  • Model: Galaxy Mk1
  • Spec: 1900TDI
  • Region: South East
Re: Speedo and fuel gauge problems
« Reply #1 on: June 16, 2015, 02:28:25 PM »
On further investigation. The beeping is being caused by the low fuel warning signal. It would appear that that the speedometer is not working and the fuel reading is a power on/power off problem. Both seem linked as they occurred at the same time. Hope that may be off help to any helping bods. ty

Offline insanitybeard

  • Greetings from Mr Chick!
  • *
  • Posts: 2427
  • Thanked: 71
  • Model: Galaxy Mk2
  • Spec: '54 130ps TDI Ghia
  • First Name: Paul
  • Region: South West
  • Country: United Kingdom
Re: Speedo and fuel gauge problems
« Reply #2 on: June 17, 2015, 06:04:45 PM »
What year is your Galaxy? I'm fairly sure I've read somewhere before that a dodgy earth (possibly in the engine bay?) could be responsible for causing various instrument cluster problems, but it'll need the input from some of the other guys here to be any more specific than that I'm afraid.
Always learning..... Often by mistakes!

 

Related Topics

  Subject / Started by Replies Latest
1 Replies
3081 Views
Latest August 13, 2012, 12:01:54 PM
by Mirez
2 Replies
5030 Views
Latest November 25, 2012, 06:40:19 PM
by andy247gtr
0 Replies
2968 Views
Latest December 03, 2012, 09:37:27 PM
by Kdence
2 Replies
3472 Views
Latest June 23, 2013, 09:59:01 PM
by Scottyboy
2 Replies
2122 Views
Latest February 26, 2014, 08:44:06 AM
by delbwoy2003
2 Replies
2386 Views
Latest August 25, 2015, 05:31:21 PM
by RossT

Advertisement: