Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy Mk3 Forum:

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca?

Mk1 and Mk2 VW Sharan Mk1 and Mk2 Ford Galaxy Mk1 and Mk2 SEAT AlhambraFord C-Max B-MaxVW Tiguan VW Touran Mk3 Ford GalaxyMk3 VW SharanMk3 SEAT AlhambraVW T4 T5 Caravelle TransporterFord Tourneo Connect VW Touareg

Author Topic: 07 Galaxy tdci Zetec battery keeps draining  (Read 7283 times)

Offline nobby1112

  • Default User Group
  • New Users
  • *
  • Posts: 2
  • Thanked: 0
  • Model: Galaxy Mk3
  • Spec: 07 tdci zetec
07 Galaxy tdci Zetec battery keeps draining
« on: December 02, 2012, 09:34:16 am »
Hi am new here so be gentle with me LOL
My 07 ford galaxy tdci zetec keepS draining the battery it doesn't always do it usually every 3-4 weeks it wont start had the rac out who confirmed that it is an intermittent power drain but as he was trying to test it it stopped doing it he was thinking that he could hear a relay clicking just as an add on don't know if its relevant but sometimes the n/s indicator doesn't work again told its an intermittent fault not covered by warranty LOL the cluster screen sometimes goes blank but comes back on if you remove the fuse and put it back in again and this last time its gone flat the air-bag light has come on am getting really confused with it HELP PLEASE

Offline gregers

  • Global Moderator
  • Accredited Users
  • *
  • Posts: 1710
  • Thanked: 13
  • Model: Transporter
  • Spec: vw t28 camper
  • First Name: greg
  • Region: East Midlands
  • Country: United Kingdom
Re: 07 Galaxy tdci Zetec battery keeps draining
« Reply #1 on: December 02, 2012, 06:04:16 pm »
 welcome5

does your dash power down when you lock the car?
i know on the smax(basically the same car)there are reports of this and iirc it was to do with the alarm module found under the passenger wheel arch????
vw t5 camper van.
reality is for people with no imagination
rip dad 21/12/10
rip mum 3/5/16
rip bruv 11/5/17
The FordMPV.com Forum - The free forum for questions and answers relating to the Ford Galaxy, S-Max and C-Max

Offline nobby1112

  • Default User Group
  • New Users
  • *
  • Posts: 2
  • Thanked: 0
  • Model: Galaxy Mk3
  • Spec: 07 tdci zetec
Re: 07 Galaxy tdci Zetec battery keeps draining
« Reply #2 on: December 02, 2012, 07:17:26 pm »
Hi the dash clears as soon as the car is locked but I have only just started checking it so not 100% sure

Offline arroanne

  • Default User Group
  • New Users
  • *
  • Posts: 1
  • Thanked: 0
  • Model: Galaxy Mk3
  • Spec: 12 titainium x 1.6
Re: 07 Galaxy tdci Zetec battery keeps draining
« Reply #3 on: February 09, 2013, 02:03:40 pm »
hi i have a very annoying drainage problem on my 12 reg 1.6 titainium x diesel 7 months old its been to ford garages for tests 5 times in last 3 months  results say battery ok, charge rate ok, drainage nil, yet if i leave it stood for 4-5 days and go to start flat battery,i did 70 miles one day last week went to start it 3 days after and had a flat battery they came up with all sorts of reasons why it may be going flat all apart from maybe one do not apply the one that may is that i dont use it everyday and do 100 miles a day (just for sake of keeping battery partly charged )as they say an alternator never fully charges a battery,any solutions anyone cos ime at wits end with it never knowing when its going to start.

Offline Chrispb

  • Mindsaysyesbodysaysnono
  • Administrator
  • Accredited Users
  • *
  • Posts: 3102
  • Thanked: 123
  • Model: Galaxy Mk2 Auto
  • Spec: 52reg TDI 115 Ghia
  • First Name: Chris
  • Region: South East
  • Country: United Kingdom
Re: 07 Galaxy tdci Zetec battery keeps draining
« Reply #4 on: February 09, 2013, 04:04:50 pm »
Hello arroanne  [W4] to our forum

Unusual to hear a new car having problems starting so soon but short journeys especially this time of year imposes a great load on the battery, so if the car is used infrequently on short journeys the battery doesn't have time to recover so it's only a matter of time before trouble occurs.

Just a couple of questions,

1.When you say it goes flat does that mean completely dead no lights or anything or lights come on but not enough power to start.

2. Assumming the battery has been on charge by battery charger if so how long for? a battery in that low state will need a minimum of 36 hrs to recharge correctly.
2016 Vauxhall Insignia Elite Nav in White 2.0CDTI Manual.
2009 Kia Sedona GS In Black 2.9CRDI 183PS. 5 Speed Manual WAV.
2003 MK2 Galaxy Ghia In Solid Black 1.9 TDI 115PS. 5 Speed Automatic.

Upgraded Eberspaecher booster heater  to independent heating with 7 day timer.

With VCDS lite (full version) need a code clearing or want to scan for faults in the north kent area, PM me.
All for a pint of Strongbow.

The FordMPV.com Forum - The free forum for questions and answers relating to the Ford Galaxy, S-Max and C-Max

Offline gregers

  • Global Moderator
  • Accredited Users
  • *
  • Posts: 1710
  • Thanked: 13
  • Model: Transporter
  • Spec: vw t28 camper
  • First Name: greg
  • Region: East Midlands
  • Country: United Kingdom
Re: 07 Galaxy tdci Zetec battery keeps draining
« Reply #5 on: February 09, 2013, 08:21:35 pm »
 welcome5 arroanne,
im wondering if it MAY be the same sort of problem that the smax can suffer from,the alarm module thats found iirc under the passenger wing area,apparently they malfunction and can drain the battery.
stab in the dark,ask the dealer about this.
vw t5 camper van.
reality is for people with no imagination
rip dad 21/12/10
rip mum 3/5/16
rip bruv 11/5/17
The FordMPV.com Forum - The free forum for questions and answers relating to the Ford Galaxy, S-Max and C-Max

Offline pforpomee

  • Default User Group
  • New Users
  • *
  • Posts: 1
  • Thanked: 0
  • Model: Galaxy Mk3
  • Spec: 2.0
  • Region: Scotland
Re: 07 Galaxy tdci Zetec battery keeps draining
« Reply #6 on: November 10, 2014, 03:18:30 pm »
hi i have mk3 last wk problem with starting call AA he cheak the vehical and said earth wire problem so u cheak all negitive wire its fit with body one near batterry one with starter motor and there is one more but i dont know they were rusty fix them then see after this my car start fine i drive more then 300 miles every wk

 

Related Topics

  Subject / Started by Replies Last Post
8 Replies
17645 Views
Last Post October 21, 2012, 03:26:37 pm
by govman333
9 Replies
4719 Views
Last Post August 09, 2013, 09:29:36 am
by Chrispb
1 Replies
4095 Views
Last Post January 02, 2018, 10:56:46 am
by Mirez
4 Replies
1869 Views
Last Post June 06, 2018, 11:54:43 am
by mike wilson
22 Replies
691 Views
Last Post January 12, 2021, 08:37:23 pm
by insanitybeard
5 Replies
383 Views
Last Post February 09, 2021, 02:15:37 pm
by brianh

Advertisement: