Welcome, Guest. Please login or register.
Did you miss your activation email?
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

Site Notification:

FordMPV is currently experiencing service disruption caused by a database error.
A backup of the database has been restored but new member registrations are currently not possible.

We Support:


Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy Mk3 Forum:

Author Topic: Drivers side electrical problems  (Read 76 times)

Offline Bunniedon

  • *
  • Posts: 1
  • Thanked: 0
  • Model: Galaxy Mk3
  • Spec: 2006 2.0tdci
  • First Name: Tony
  • Region: West Midlands
Drivers side electrical problems
« on: September 27, 2021, 04:54:25 PM »
Hi all came across this site when trying to find and answer to an issue I'm having on my misses car

1st the o/s passenger window stopped working and I can only lock it manually, then the drivers window a few weeks later. Sometimes on the dash it will say driver door open even though it is locked.

Then to top it off the switches on the drivers door fully stopped working

I've done a few things e.g

I changed the 4 25amp fuses in the rear fuse box and that made the passenger window work for around 5 mins then it stops again

I disconnect the battery to "reset" everything. I got all the windows down using the fob but now the drivers one wont close

I purchased and new (used) loom, door control unit and switch for the drivers door and still had no luck

I genuinely dont know what else to try

Any sort of help or pointers would be much appreciated

 

Advertisement: