Welcome, Guest. Please login or register.
Did you miss your activation email?
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

We Support:


Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy Mk3 Forum:

Author Topic: engine coolant temperature sensor  (Read 2230 times)

Offline GethThomas

  • *
  • Posts: 29
  • Thanked: 5
  • Model: Galaxy Mk3
  • Spec: 2.0. petrol, 2007
  • Region: North Wales
engine coolant temperature sensor
« on: February 18, 2014, 11:13:18 AM »
Hi, first time here. I have a '07 2litre petrol galaxy, can anyone help me find the engine coolant temp sensor please? Gauge moves to just under 1/2 way when idling, but drops to cold when travelling. Cabin is lovely and warm so heater matrix ok, and coolant levels ok. I have a P0420 error code (inefficient catalytic converter), but want to fix temp sensor first...

 

Advertisement:


SMF spam blocked by CleanTalk