Welcome, Guest. Please login or register.
Did you miss your activation email?
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy Mk3 Forum:

Author Topic: Full beam not working on left side  (Read 45 times)

Offline barnettgs

  • *
  • Posts: 6
  • Thanked: 1
  • Model: Galaxy Mk3
  • Spec: 2011 2.0 TDCI
  • Region: North Ireland
Full beam not working on left side
« on: November 07, 2020, 01:56:41 PM »
Full beam on left side doesn't work so replacing it with a new bulb and that didn't help and also swapped the bulbs from right to left just to be sure that new bulb isn't broken, still the same.

I tested the voltage to the headlamp with multimeter, it is just 4v, should be around 12v like the other side but I think it might be down to relay or something? 

I could not find any information about location fuse/relay for Ford Galaxy MK3?  Does same fuse covers both sides or just one side?  However, I did find some information on MK4 Ford Mondeo but not sure if they share the same fuse boxes/relays with Galaxy MK3.

I might need to take it to the auto electrician to find the cause.

 

Advertisement:


SMF spam blocked by CleanTalk