Welcome, Guest. Please login or register.
Did you miss your activation email?
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

Site Notification:

FordMPV is currently experiencing service disruption caused by a database error.
A backup of the database has been restored but new member registrations are currently not possible.

We Support:


Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy Mk3 Forum:

Author Topic: Galaxy instrument panel  (Read 2896 times)

Offline stephendavid33

  • *
  • Posts: 14
  • Thanked: 0
  • Model: Galaxy Mk3
  • Spec: 2012
  • Region: North Ireland
Galaxy instrument panel
« on: July 12, 2014, 11:55:37 AM »
can you please have a look at the instrument panel photo - I am worried about the temp display this seems to indicate 60 c plus I have a warning light for stop bulbs yet the brake lights are working fine.

Starting to think I bought a dodgy vehicle!

Picture below.

Offline Chrispb

  • Mindsaysyesbodysaysnono
  • *
  • Posts: 3095
  • Thanked: 121
  • Model: Galaxy Mk2 Auto
  • Spec: 52reg TDI 115 Ghia
  • First Name: Chris
  • Region: South East
  • Country: United Kingdom
Re: Galaxy instrument panel
« Reply #1 on: July 12, 2014, 12:41:32 PM »
Possible sensor fault on the temp display, usually located behind front bumper/grill.
Have you actually looked at the bulbs? if they have gone black I would change them anyway.
Are all segments of the high level lamp working OK
2016 Vauxhall Insignia Elite Nav in White 2.0CDTI Manual.
2009 Kia Sedona GS In Black 2.9CRDI 183PS. 5 Speed Manual WAV.
2003 MK2 Galaxy Ghia In Solid Black 1.9 TDI 115PS. 5 Speed Automatic.

Upgraded Eberspaecher booster heater  to independent heating with 7 day timer.

With VCDS lite (full version) need a code clearing or want to scan for faults in the north kent area, PM me.
All for a pint of Strongbow.

The FordMPV.com Forum - The free forum for questions and answers relating to the Ford Galaxy, S-Max and C-Max

Offline Mirez

  • Pondering the next mod...
  • *
  • Posts: 3755
  • Thanked: 173
  • Model: Galaxy Mk2
  • Spec: 03 115PS Ghia
  • First Name: Mark
  • Region: South West
  • Country: United Kingdom
Re: Galaxy instrument panel
« Reply #2 on: July 12, 2014, 01:00:20 PM »
Nice and toasty where you are :)

60*c will be an upper limit caused by a faulty sensor. I'm not sure how they work on the Mk3 but normally the higher the resistance the warmer it is so if its not connected then it could/would indicate 60.

Stop lamps as Chris says take them out and have a look, could be a faulty bulb that's causing that or someone's changed them to LED and the computer can't detect the correct resistance.
03 Ford Galaxy 1.9 TDI 115 Ghia in Spruce Green Metallic
With cream leather interior, Full Bodykit, Remapped at 145bhp, Lowered on 18's
08 Ford Transit 2.2 TDI 115 in Frozen White
With retrofitted everything except another slidey door! :)

VCDS HEX/CAN - Scans/Coding done in Wiltshire in exchange for winegums! :)

Offline stephendavid33

  • *
  • Posts: 14
  • Thanked: 0
  • Model: Galaxy Mk3
  • Spec: 2012
  • Region: North Ireland
Re: Galaxy instrument panel
« Reply #3 on: July 12, 2014, 07:10:53 PM »
Thx just noticed that the top rear brake light has gone  - the long bulb.
As I only have this car for a week I would expect the dealer to sort. If not is this an easy replacement in terms of access to the bulb. Many thx.

Ps this car is only 2 years old I am worried as the parking sensors are playing up, the fuel cap needed repair, the outside temp sensor is broke and now this.   Seems mad - any advice

Offline Chrispb

  • Mindsaysyesbodysaysnono
  • *
  • Posts: 3095
  • Thanked: 121
  • Model: Galaxy Mk2 Auto
  • Spec: 52reg TDI 115 Ghia
  • First Name: Chris
  • Region: South East
  • Country: United Kingdom
Re: Galaxy instrument panel
« Reply #4 on: July 12, 2014, 07:17:50 PM »
Am sure that one is led and will require a whole replacement and probably expensive.
Of course it could be a wiring fault through the tailgate gaiter or bad connection on the lamp.
2016 Vauxhall Insignia Elite Nav in White 2.0CDTI Manual.
2009 Kia Sedona GS In Black 2.9CRDI 183PS. 5 Speed Manual WAV.
2003 MK2 Galaxy Ghia In Solid Black 1.9 TDI 115PS. 5 Speed Automatic.

Upgraded Eberspaecher booster heater  to independent heating with 7 day timer.

With VCDS lite (full version) need a code clearing or want to scan for faults in the north kent area, PM me.
All for a pint of Strongbow.

The FordMPV.com Forum - The free forum for questions and answers relating to the Ford Galaxy, S-Max and C-Max

Offline gregers

  • *
  • Posts: 1711
  • Thanked: 13
  • Model: Transporter
  • Spec: vw t28 camper
  • First Name: greg
  • Region: East Midlands
  • Country: United Kingdom
Re: Galaxy instrument panel
« Reply #5 on: July 12, 2014, 08:29:35 PM »
iirc its a wiring fault in the loom somewhere,also believe its a common problem.known issue.
i have the same problem,changed the bulb iirc its a balde type jobby and it blew instantly.its  P.I.A to change as you have to remove the plastic trim on the hatch,as you have said let the dealer sort it out.
vw t5 camper van.
reality is for people with no imagination
rip dad 21/12/10
rip mum 3/5/16
rip bruv 11/5/17
The FordMPV.com Forum - The free forum for questions and answers relating to the Ford Galaxy, S-Max and C-Max

 

Advertisement: