Welcome, Guest. Please login or register.
Did you miss your activation email?
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

We Support:


Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy Mk3 Forum:

Author Topic: Galaxy MKIII steering pump noise  (Read 292 times)

Offline rayastero

  • *
  • Posts: 4
  • Thanked: 0
  • Model: Galaxy Mk3
  • Spec: 2,0 flexyfuel 2007
  • First Name: Urmas
  • Region: Non UK
Galaxy MKIII steering pump noise
« on: October 15, 2020, 01:53:30 PM »
Hi

I would need some help.

Ford Galaxy 2007 (2,0 flexyfuel) power steering makes noise. Started a month ago on the road after ab 90 km of driving. Noise is high, whining, constant. When I stopped the engine for about 30 min and then again started the engine, the noise was gone.
Later the noise got more frequent. Already after driving 5 km.

Changed the power steering pump. New fluid, new belt. But the new pump made even louder noise.
Asked the mechanic to fix it, they changed the pump once again, now the noise is a bit quieter, but still there.
Any ideas, what might be the problem?


Thanks!
Urmas

Offline brianh

  • *
  • Posts: 992
  • Thanked: 163
  • Model: Galaxy Mk2
  • Spec: 2001 2.3 Ghia LPG
  • First Name: Brian
  • Region: South East
  • Country: United Kingdom
Re: Galaxy MKIII steering pump noise
« Reply #1 on: October 15, 2020, 07:25:44 PM »
I have a feeling some of the mk3 suffer with a blocked filter in the reservoir for the pas fluid, Did they replace the reservoir or at least clean the filter out?

Offline rayastero

  • *
  • Posts: 4
  • Thanked: 0
  • Model: Galaxy Mk3
  • Spec: 2,0 flexyfuel 2007
  • First Name: Urmas
  • Region: Non UK
Re: Galaxy MKIII steering pump noise
« Reply #2 on: October 15, 2020, 07:41:40 PM »
Hello

Thank you for the idea. They did not replace it. Good to know and I will deal with it. I hope the problem lies there.

Best regards
Urmas

Offline rayastero

  • *
  • Posts: 4
  • Thanked: 0
  • Model: Galaxy Mk3
  • Spec: 2,0 flexyfuel 2007
  • First Name: Urmas
  • Region: Non UK
Re: Galaxy MKIII steering pump noise
« Reply #3 on: December 04, 2020, 02:01:03 PM »
Hi again.

So, here I am again with my problem.
The workshop could not solve the problem. Said they tried different new pumps, noise was still there.
Then I turned to Ford service in order to find the cause of the problem. When I got my car back they said they found no leaks. Said I need to replace generator clutch. The noise was gone (or at least not so loud anymore).
Went back to the original workplace and they offered to change the generator clutch for free. Well, I was glad, because I had been by them for a few times already and each day without a car (3 kids) is a problem for me.
Now- the noise is back! Came slowly back after about a week.
Can it be that Ford did not really check the system (pressure test), only visual check? There has to be some place where air gets into the system and makes the power streeing pump whine.
Any ideas?


Thanks!
Urmas



Offline SirDavidAlhambra

  • Sir David Alhambra.
  • *
  • Posts: 738
  • Thanked: 18
  • Model: Alhambra Mk2 Auto
  • Spec: 2006 1.9 Tdi auto
  • First Name: Dave
  • Region: South East
  • Country: United Kingdom
Re: Galaxy MKIII steering pump noise
« Reply #4 on: December 13, 2020, 12:49:31 PM »
Was the mechanic expecting a different result when he (or she) did for a second time what didn't work the first time?

What I would do is give him (or her) a book about "scientific method" and then take ur car elsewhere
I drive a Seat Alhambra 1.9Tdi which has 115bhp and an automatic gearbox.

I am happy to help you with all your questions. I am not a qualified mechanic but seem to be better at fixing my car than even the most experienced garages.

I have lots of friends here and very much enjoy talking with you all.

Always remember, a motor car is a serious tool and should be treated with respect. Put your safety first, always.

Offline rayastero

  • *
  • Posts: 4
  • Thanked: 0
  • Model: Galaxy Mk3
  • Spec: 2,0 flexyfuel 2007
  • First Name: Urmas
  • Region: Non UK
Re: Galaxy MKIII steering pump noise
« Reply #5 on: December 13, 2020, 08:47:39 PM »
On Friday I visited the Ford mechanics. They replaced the power steering fluid reservoir. The pump is quiet for now (I can hear it, but it's not so whiny). So far, so good. Guess it's time to look for something fresher to drive around.

Thanks for sharing your thoughts!

Offline SirDavidAlhambra

  • Sir David Alhambra.
  • *
  • Posts: 738
  • Thanked: 18
  • Model: Alhambra Mk2 Auto
  • Spec: 2006 1.9 Tdi auto
  • First Name: Dave
  • Region: South East
  • Country: United Kingdom
Re: Galaxy MKIII steering pump noise
« Reply #6 on: December 13, 2020, 10:27:11 PM »
Fingers crossed. Remember, the best value car on the market is usually the one you currently own.
I drive a Seat Alhambra 1.9Tdi which has 115bhp and an automatic gearbox.

I am happy to help you with all your questions. I am not a qualified mechanic but seem to be better at fixing my car than even the most experienced garages.

I have lots of friends here and very much enjoy talking with you all.

Always remember, a motor car is a serious tool and should be treated with respect. Put your safety first, always.

Offline mike wilson

  • *
  • Posts: 505
  • Thanked: 20
  • Model: Galaxy Mk3
  • Spec: 14 TitX 2.0TDCI
  • Region: North East
  • Country: United Kingdom
Re: Galaxy MKIII steering pump noise
« Reply #7 on: December 18, 2020, 03:06:33 PM »
Have had a similar issue with my Mondeo; curently on pump number three and gone in for another try.  This time, I went to a breaker and bought an original, low mileage fitment.  The problem seems to be in the remanufactured pumps.  Can't find a properly new one anywhere* and the reman ones seem to fail at the slightest stress.  Will see after Christmas if I am right.

*Unless i go to Ford and bend over the counter.  Even then.....

 

Advertisement:


SMF spam blocked by CleanTalk