Welcome, Guest. Please login or register.
Did you miss your activation email?
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy Mk3 Forum:

Author Topic: GLOW PLUG FAULT????  (Read 122 times)

Offline triton650

  • *
  • Posts: 2
  • Thanked: 0
  • Model: Galaxy Mk3
  • Spec: 2009 2.0 Tdi Zetec
  • First Name: dave
  • Region: East Midlands
  • Country: United Kingdom
GLOW PLUG FAULT????
« on: September 29, 2020, 08:22:07 PM »
After 100 miles on a 200 mile journey engine malfunction light came on went into lymph mode pulled in stopped restarted light off.Carried on with rest of journey no problem.Taken 2009 2l cdi to garage they say glow plug fault blown glow plug fuse 60amp.
Maybe im thick but i thought glow plugs only needed on start up not after 100 miles.
Any suggestions?????

Offline johnnyroper

  • *
  • Posts: 2982
  • Thanked: 150
  • Model: Galaxy Mk2
  • Spec: 02 tdi 115 ghia
  • Region: South West
  • Country: United Kingdom
Re: GLOW PLUG FAULT????
« Reply #1 on: September 29, 2020, 11:58:29 PM »
Typically they do only need glow on cold start but more modern diesels
also use glow when regenerating. I see you say you have a mark 2 on a 2009 reg??  Can I assume itís actually a mark 3 on a 2009 that could be a common rail DPF equipped car?

Offline triton650

  • *
  • Posts: 2
  • Thanked: 0
  • Model: Galaxy Mk3
  • Spec: 2009 2.0 Tdi Zetec
  • First Name: dave
  • Region: East Midlands
  • Country: United Kingdom
Re: GLOW PLUG FAULT????
« Reply #2 on: October 01, 2020, 07:43:04 PM »
sorry a mark 3 2009 zetec tdi

 

Advertisement:


SMF spam blocked by CleanTalk