Ford and Volkswagen MPV Forums

Large MPVs -- Ford Galaxy / VW Sharan / SEAT Alhambra: => Mk3 Ford Galaxy / Ford S-Max => Topic started by: Shahid Ali Abbasi on December 18, 2017, 02:29:09 PM

Title: MPG and Fuel Tank Level Miles to Empty not showing
Post by: Shahid Ali Abbasi on December 18, 2017, 02:29:09 PM
Hi all,
I have Ford Galaxy Zetec 2011. It takes long to start and also after a mild Drive the distance to empty and miles per gallon goes dot dot dot. And the engine also has stranger does wireless start so there seems to be some problem with the pumping system or somethig. Can someone help please before I am ripped off by a mechanic.

Regards
Title: Re: MPG and Fuel Tank Level Miles to Empty not showing
Post by: gregers on December 19, 2017, 09:30:06 PM
have you checked the on board diagnostic menu for any fault codes?
Title: Re: MPG and Fuel Tank Level Miles to Empty not showing
Post by: Shahid Ali Abbasi on December 20, 2017, 10:07:53 PM
The Diagnostic on dash shows miles to empty, mpg (miles per gallon), fuel flow, etc only for a few minutes and then all these readings related to level and fuel flow just go ----. The diagnostics showed fault code P0087 Fuel Rail/System Pressure Too Low.

Now the mechanic has removed the injector pump, saying that the pump is faulty. But my gut feeling says its the pump inside the fuel tank that is not pushing the fuel forward to the filter and then to the injector pump. The mechanic says there is no pump in the tank; its just the gauge. But somehow I cannot believe that a fuel pump could have such a long suction line going back to the filter and then to the fuel tank. also, when I removed the pipe from the fuel filter inlet and turned the key to "On", without starting the engine, no fuel came out where as, I think, the in tank fuel pump must start pumping fuel as soon as we rotate the key to "On" position (not ignition).

Can you please guide me in these:
1. Is there a pump in 2011 Ford Galaxy Zetec?
2. If yes, then does it start pumping as soon as the key is swung to "On", not ignition?

earliest replies would be much appreciated.

Regards

Title: Re: MPG and Fuel Tank Level Miles to Empty not showing
Post by: Shahid Ali Abbasi on December 20, 2017, 10:23:53 PM
sorry there are some mistakes in the last reply so please consider this instead:

The Diagnostic on dash shows miles to empty, mpg (miles per gallon), fuel flow, etc only for a few minutes and then all these readings related to level and fuel flow just go ----. The diagnostics showed fault code P0087 Fuel Rail/System Pressure Too Low.

Now the mechanic has removed the injector pump from the engine, saying that the pump is faulty. But I strongly believe its the pump inside the fuel tank that is not pushing the fuel forward to the filter and then to the injector pump. The mechanic says there is no pump in the tank; its just the gauge. But somehow I cannot believe that a fuel pump could have such a long suction line going back to the filter and then to the fuel tank. Also, when I disconnected the pipe from the fuel filter inlet and turned the key to "On", without starting the engine, no fuel came out where as, I think, the in tank fuel pump must start pumping fuel as soon as we rotate the key to "On" position (not ignition). Thus, the fuel should have come out of the disconnected pipe.

Can you please guide me in these:
1. Is there a pump in the Tank 2011 Ford Galaxy 2.0 Diesel Zetec?
2. If yes, then does it start pumping as soon as the key is swung to "On", not ignition?
3. and if its not working, will the engine side fuel injector pump still work and start the engine?

Earliest replies would be much appreciated.

Regards
Title: Re: MPG and Fuel Tank Level Miles to Empty not showing
Post by: Mirez on December 20, 2017, 10:52:21 PM
In future, one post is all thats needed. Please don't start multiple topics on the same subject ;)

1) No pump on the Mk3
2) N/A
3) Yes, clearly :)

Pull the cover off the engine and look on the left side, its not at all uncommon for the top fuel line to rub through on the cover enough to allow air into the system. Look for signs of rubbing, rarely will it look like a leak.
Title: Re: MPG and Fuel Tank Level Miles to Empty not showing
Post by: johnnyroper on December 20, 2017, 11:26:04 PM
Also if the mark 3 is anything like the 2.0tdci fitted to Mondrian/x type jag check the injector leak off pipes as they can split/fracture at injectors causing air to enter system and leak back to tank.