Welcome, Guest. Please login or register.
Sign in with Facebook Sign in with Twitter Sign in with Google Sign in with Linkedin Sign in with Microsoft

Hello! Welcome to the Ford and Volkswagen MPV / SUV Forums.
Dedicated forums for the Ford Galaxy, S-Max, C-Max, B-Max and Kuga.
User groups for the SEAT Alhambra, Volkswagen Sharan, Touran, Tiguan and Touareg!

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca 

 Mk1 and Mk2 VW Sharan  Mk1 and Mk2 Ford Galaxy  Mk1 and Mk2 SEAT Alhambra  Ford C-Max B-Max  VW Tiguan  VW Touran  Mk3 Ford Galaxy  Mk3 VW Sharan  Mk3 SEAT Alhambra  VW T4 T5 Caravelle Transporter  Ford Tourneo Connect  VW Touareg

Advertisement:


Recent Forum Topics:

Google Translate:

Ford Galaxy Mk3 Forum:

Author Topic: Turbo overboost - lack of power :(  (Read 6462 times)

Offline ga73

  • *
  • Posts: 14
  • Thanked: 0
  • Model: Galaxy Mk3
  • Spec: 07 tdci 140 ghia X
  • First Name: Gary
  • Region: North West
Turbo overboost - lack of power :(
« on: June 27, 2014, 01:35:04 PM »
Hi all,

Apologies as this is my first post but only just bought my 07 plate mk3 Galaxy 2.0 TDCI Ghia, on driving it back from Scotland it seemed a little down on power compared to my 407 HDI 130 but i assumed just because it was a larger vehicle, however after plugging into diagnosis im getting an error code P0003 which shows Turbo/Supercharger overboost... from what i can read online the fix is removing the turbo and cleaning it but I cant find any guides on removing the turbo...

Can anyone give me some advise or some way of cleaning without removing the turbo that actually works..

Many thanks

Gary

Offline ga73

  • *
  • Posts: 14
  • Thanked: 0
  • Model: Galaxy Mk3
  • Spec: 07 tdci 140 ghia X
  • First Name: Gary
  • Region: North West
Re: Turbo overboost - lack of power :(
« Reply #1 on: June 28, 2014, 12:58:58 AM »
Anyone?  :-(

Offline Chrispb

  • Mindsaysyesbodysaysnono
  • *
  • Posts: 2979
  • Thanked: 91
  • Model: Galaxy Mk2 Auto
  • Spec: 52reg TDI 115 Ghia
  • First Name: Chris
  • Region: South East
  • Country: United Kingdom
Re: Turbo overboost - lack of power :(
« Reply #2 on: June 28, 2014, 08:53:44 AM »
Hello and  welcome5

Info for the MK3 is still pretty scarce even though it's been out since 2006.

This is all I can help you with but would suggest the normal service items like fuel and air filter are changed first and a diagnostic scan to see if any thing has been logged.







2009 Kia Sedona GS In Black 2.9CRDI 183PS. 5 Speed Manual WAV.
2003 MK2 Galaxy Ghia In Solid Black 1.9 TDI 115PS. 5 Speed Automatic.

Upgraded Eberspächer booster heater  to independent heating with 7 day timer.

With VCDS lite (full version) need a code clearing or want to scan for faults in the north kent area, PM me.
All for a pint of Strongbow.

The FordMPV.com Forum - The free forum for questions and answers relating to the Ford Galaxy, S-Max and C-Max

Offline Chrispb

  • Mindsaysyesbodysaysnono
  • *
  • Posts: 2979
  • Thanked: 91
  • Model: Galaxy Mk2 Auto
  • Spec: 52reg TDI 115 Ghia
  • First Name: Chris
  • Region: South East
  • Country: United Kingdom
Re: Turbo overboost - lack of power :(
« Reply #3 on: July 11, 2014, 01:34:06 PM »
Done a bit of research on MK3 overboost, it appears the MK3 has an electronic actuator that has poor solder connections inside.
Here is a piccy from the net that shows possible faulty connections.

Symptoms glow plug light flashing, limp mode and fault code P2263



2009 Kia Sedona GS In Black 2.9CRDI 183PS. 5 Speed Manual WAV.
2003 MK2 Galaxy Ghia In Solid Black 1.9 TDI 115PS. 5 Speed Automatic.

Upgraded Eberspächer booster heater  to independent heating with 7 day timer.

With VCDS lite (full version) need a code clearing or want to scan for faults in the north kent area, PM me.
All for a pint of Strongbow.

The FordMPV.com Forum - The free forum for questions and answers relating to the Ford Galaxy, S-Max and C-Max

Offline ga73

  • *
  • Posts: 14
  • Thanked: 0
  • Model: Galaxy Mk3
  • Spec: 07 tdci 140 ghia X
  • First Name: Gary
  • Region: North West
Re: Turbo overboost - lack of power :(
« Reply #4 on: July 19, 2014, 09:53:20 PM »
Thanks Chris,

I havent had the fault code P2263 although do have a few others that i've listed in another post! :(

Hope i havent bought a money pit !

Offline johnboyad07

  • *
  • Posts: 6
  • Thanked: 0
  • Model: Galaxy Mk3 Auto
  • Spec: 2007
  • First Name: john
  • Region: East Anglia
Re: Turbo overboost - lack of power :(
« Reply #5 on: September 04, 2016, 08:14:30 PM »
Hi prob got a sticky wastegate like mine mine came up when I was on the a1 going north to scotland

Offline ebo555

  • *
  • Posts: 12
  • Thanked: 0
  • Model: Galaxy Mk3
  • Spec: Ghia
  • First Name: Ian
  • Region: London
Re: Turbo overboost - lack of power :(
« Reply #6 on: September 07, 2016, 01:37:03 AM »
Anyone?  :-(

I'd recommend you eliminate the more basic stuff first  - like split/loose intercooler hoses.   Are you hearing any whistling rushing thru the air vents?

I had an overboowt error a couple of months ago and it turned out to be a split hose and an easy £20 fix.

Ebo 


Offline SirDavidAlhambra

  • Sir David Alhambra.
  • *
  • Posts: 354
  • Thanked: 3
  • Model: Alhambra Mk2 Auto
  • Spec: 2006 1.9 Tdi auto
  • First Name: Dave
  • Region: South East
  • Country: United Kingdom
Re: Turbo overboost - lack of power :(
« Reply #7 on: June 15, 2019, 10:20:08 PM »
Surely a split hose would cause underboost not overboost?!
I drive a Seat Alhambra 1.9Tdi which has 115bhp and an automatic gearbox.

I am happy to help you with all your questions. I am not a qualified mechanic but seem to be better at fixing my car than even the most experienced garages.

I have lots of friends here and very much enjoy talking with you all.

Always remember, a motor car is a serious tool and should be treated with respect. Put your safety first, always.

Offline brianh

  • *
  • Posts: 618
  • Thanked: 61
  • Model: Galaxy Mk2
  • Spec: 2001 2.3 Ghia LPG
  • First Name: Brian
  • Region: South East
  • Country: United Kingdom
Re: Turbo overboost - lack of power :(
« Reply #8 on: June 16, 2019, 05:30:32 PM »
Depends what the hose connects to - if its a vacuum hose operating something else, then the split stops it controlling what it should do.

 

Related Topics

  Subject / Started by Replies Latest
9 Replies
8355 Views
Latest June 24, 2012, 04:41:26 PM
by lavill78
5 Replies
2731 Views
Latest August 18, 2017, 10:34:32 AM
by Kristaps Baltais
29 Replies
9301 Views
Latest July 14, 2014, 09:56:54 AM
by julieade
6 Replies
3128 Views
Latest October 17, 2014, 09:43:47 PM
by gregers
7 Replies
2918 Views
Latest December 08, 2015, 08:51:45 AM
by johnnyroper
1 Replies
921 Views
Latest April 12, 2018, 11:03:47 PM
by johnnyroper

Advertisement: