Advert:


Recent Forum Topics:

Google Translate:

Ford Galaxy Mk3 Forum:

Owners Forums for Ford and Volkswagen MPVs / SUVs

Ford Galaxy S-Max C-Max B-Max Tourneo Connect / Volkswagen Sharan Touran Tiguan Touareg Caravelle / SEAT Alhambra Alteca?

Mk1 and Mk2 VW Sharan Mk1 and Mk2 Ford Galaxy Mk1 and Mk2 SEAT AlhambraFord C-Max B-MaxVW Tiguan VW Touran Mk3 Ford GalaxyMk3 VW SharanMk3 SEAT AlhambraVW T4 T5 Caravelle TransporterFord Tourneo Connect VW Touareg

Author Topic: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???  (Read 767 times)

Offline Eurotrotter

  • Default User Group
  • Standard Users
  • *
  • Posts: 8
  • Thanked: 0
  • Model: S-Max
  • Spec: 2006 1.8 DIESEL
  • First Name: Josh
  • Region: East Anglia
WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« on: March 24, 2021, 10:46:53 am »
Hello ,
I am puzzled why my SMAX has 2 brake pedal switches one blue and white , the other all black ???

I was more puzzled to see that the wire going to the faulty  high level brake LIGHT was giving only one flash of light to my power tester and going dead . The other 2 main brake lights were working , but later when I removed the black brake pedal switch , and tested it for continuity it was DEAD too and all went OFF altogether !!
Can anyone tell me what the other blue switch is for as it looks roughly the same shape as the black one and has a sort of plunger that comes into contact with brake pedal . No one has ever explained why this system has 2 switches . Can anyone explain please ? As I am about to REPLACE the black switch and see if the old one really failed ? Do these fail at all ? As made of hard plastic, I suspect it will go on a high mileage vehicle ? 

Offline SirDavidAlhambra

  • Sir David Alhambra.
  • Default User Group
  • Accredited Users
  • *
  • Posts: 897
  • Thanked: 21
  • I am Sir David Alhambra.
  • Model: Alhambra Mk2 Auto
  • Spec: 2006 1.9 Tdi auto
  • First Name: Dave
  • Region: South East
  • Country: United Kingdom
Re: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« Reply #1 on: March 24, 2021, 01:48:17 pm »
Hello, and welcome to the forum our new expressive little friend, it is lovely to make new friends who have such passion for making sure their lovely cars are in tip top condition hehe

 welcome5

Now, I am no expert by any stretch of the imagination, but I expect one of them is for the brake lights and the other is for cruise control. Remember, car electrical systems aren’t really digital yet and still use quite simple circuitry. So that’s what I expect it would be.

 8-)   [drive]
I drive a Seat Alhambra 1.9Tdi which has 115bhp and an automatic gearbox.

I am happy to help you with all your questions. I am not a qualified mechanic but seem to be better at fixing my car than even the most experienced garages.

I have lots of friends here and very much enjoy talking with you all.

Always remember, a motor car is a serious tool and should be treated with respect. Put your safety first, always.

Offline brianh

  • Default User Group
  • Accredited Users
  • *
  • Posts: 1118
  • Thanked: 227
  • Model: Galaxy Mk2
  • Spec: 2001 2.3 Ghia LPG
  • First Name: Brian
  • Region: South East
  • Country: United Kingdom
Re: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« Reply #2 on: March 24, 2021, 08:58:49 pm »
4832217 which is the black switch has a description of Switch assy - stop light
4832219 is the blue switch. Microcat "helpfully" describes this as a Switch assy. A quick google gives a much more helpful description of "Ford 4832219 Speed Control Inhibitor Switch"

So the blue one is for the cruise control (and is how the cruise control knows you've pressed the brakes). I would guess that the two may switch between states at a slightly different point of pedal pressure.

It sounds like the original switch is dead - most likely burnt or worn contacts as it will see a lot of action after all, every time you press the brakes. may have been beginning to fail and you've caught it at a bad point. As David says above on that.

As to lifespan, no idea. But if its the 2006 diesel in your description a failed switch at that age is hardly a surprise to me, particually if the car has served as a Taxi or similar in the past, as a lot of them will have done.
« Last Edit: March 24, 2021, 09:00:35 pm by brianh »

Offline Eurotrotter

  • Default User Group
  • Standard Users
  • *
  • Posts: 8
  • Thanked: 0
  • Model: S-Max
  • Spec: 2006 1.8 DIESEL
  • First Name: Josh
  • Region: East Anglia
Re: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« Reply #3 on: March 26, 2021, 04:53:23 pm »
Thanks for the reply explaining the second switch . Incidentally my vehicle model doesn't have CRUISE Control on it . I looked on the owners handbook it shows some buttons on the driving wheel but they are nowhere to be seen on mine. It's not a big deal as I can do without cruise control . Yellow speed cameras are there to remind me to keep it low !
My biggest concern is the brake light switch !! i PUT it to the test with another second hand to compare them . They are identical no doubt but when fed directly from a 12 V battery they both lit up my test prob lamp ! Plunger on light on, plunger OFF light still on !
Does that mean they both failed or am I doing something wrong in my test ???
I have an upcoming MOT Test and I just can't understand this fault , and I know I could be charged an arm and a leg by an auto electrician garage !! 
Has anyone had the same problem please ? Can anyone tell me if I have to order a brand new switch ?? Would that solve the problem ? Any suggestions before I get ripped OFF ?

Offline brianh

  • Default User Group
  • Accredited Users
  • *
  • Posts: 1118
  • Thanked: 227
  • Model: Galaxy Mk2
  • Spec: 2001 2.3 Ghia LPG
  • First Name: Brian
  • Region: South East
  • Country: United Kingdom
Re: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« Reply #4 on: March 26, 2021, 06:07:31 pm »
I don't know the part in question, but it certainly sounds like its broken if its the same in both states. I'd tend to use a multimeter to test personally. I don't know if it is usually closed or open if the plunger isn't pressed (I'd expect it to be open and closing the circuit to bring the light on) What I'd suggest to rule it out is to check with the switch disconnected what the lights are doing, then connect the two contacts on the wiring loom with a short bit of wire and see if that brings the lights on. If it does, you know your looking at the right thing.

Its possible, that the other switch does a bit more than the description lets on, and that the two main lights are operated by one switch, with the other light being operated by that. Which would make sense as a failsafe in the event of switch failure.

Offline johnnyroper

  • RL Contributor
  • Accredited Users
  • *
  • Posts: 3255
  • Thanked: 171
  • Model: Galaxy Mk2
  • Spec: 02 tdi 115 ghia
  • Region: South West
  • Country: United Kingdom
Re: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« Reply #5 on: March 26, 2021, 06:08:09 pm »
The problem with using a test probe is that won’t draw the same current as the bulbs, if switch contact is dirty and not making very good contact then it could be breaking down when load is put through it.

To test wiring have you put a feed down the wire at brake light switch to test the brake lights? Remember usually the main lights are off one contact and third brake light is off a different contact for redundancy.

Offline Eurotrotter

  • Default User Group
  • Standard Users
  • *
  • Posts: 8
  • Thanked: 0
  • Model: S-Max
  • Spec: 2006 1.8 DIESEL
  • First Name: Josh
  • Region: East Anglia
Re: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« Reply #6 on: March 26, 2021, 10:31:47 pm »
From the latest tips I came to think the main reason there 2 switches and NO CRUISE CONTROL is ... YES ! It could well be for separate circuits !  as an emergency one just like the back up rear light with 2 separate bulbs one on the gate cluster the other on the wing one .
But the Haynes manual says : The blue one is the brake position sensor switch ! I don't understand this at all .Since I don't have Cruise control at all on this model as I saw an unused CONNECTOR stuck under the dash from the factory .
I am gonna have another thorough look at the whole wiring loom system and the 2 switches and hope for the best . 

Offline Eurotrotter

  • Default User Group
  • Standard Users
  • *
  • Posts: 8
  • Thanked: 0
  • Model: S-Max
  • Spec: 2006 1.8 DIESEL
  • First Name: Josh
  • Region: East Anglia
Re: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« Reply #7 on: March 26, 2021, 10:49:52 pm »
Used a multimeter with dial on CONTINUITY .
NO response from the switch ! Either plunger's position ( i.e  PUSHED IN  or  LET OUT )  still no response at all .
And these units are of SEALED design , which means NO REPAIR is possible .

Does that mean a new one is required ?

 

Offline brianh

  • Default User Group
  • Accredited Users
  • *
  • Posts: 1118
  • Thanked: 227
  • Model: Galaxy Mk2
  • Spec: 2001 2.3 Ghia LPG
  • First Name: Brian
  • Region: South East
  • Country: United Kingdom
Re: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« Reply #8 on: March 26, 2021, 11:18:34 pm »
Used a multimeter with dial on CONTINUITY .
NO response from the switch ! Either plunger's position ( i.e  PUSHED IN  or  LET OUT )  still no response at all .
And these units are of SEALED design , which means NO REPAIR is possible .

Does that mean a new one is required ?

 

It certainly sounds that way. However doing the simple test I put above, should tell you what that switch actually does. And I'd believe your own eyes over anything printed in the Haynes manual, as personal experience with them has shown they aren't always right.

Ford TIS would be a more useful resource, but I don't have access to anything new enough to help with your model unfortunately.

Its possible the same switch gets used for the cruise control where its fitted, but is fitted either way if it does have a function beyond switching off the cruise control, It may also have some function to do with the engine management.

Offline SirDavidAlhambra

  • Sir David Alhambra.
  • Default User Group
  • Accredited Users
  • *
  • Posts: 897
  • Thanked: 21
  • I am Sir David Alhambra.
  • Model: Alhambra Mk2 Auto
  • Spec: 2006 1.9 Tdi auto
  • First Name: Dave
  • Region: South East
  • Country: United Kingdom
Re: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« Reply #9 on: March 27, 2021, 04:30:03 am »
Yes, I suspect also that the cruise control switch is used for fuelling purposes too and maybe even gearbox control in automatics. These Alhambs and Galaxies are such sophisticated vehicles. I would have thought a continuity test would tell if each switch is working or not, but maybe there is some sort of variable resistance thing going on too. I can’t imagine they are too pricey, so might be worth trying a replacement if we suspect these are playing up?
I drive a Seat Alhambra 1.9Tdi which has 115bhp and an automatic gearbox.

I am happy to help you with all your questions. I am not a qualified mechanic but seem to be better at fixing my car than even the most experienced garages.

I have lots of friends here and very much enjoy talking with you all.

Always remember, a motor car is a serious tool and should be treated with respect. Put your safety first, always.

Offline johnnyroper

  • RL Contributor
  • Accredited Users
  • *
  • Posts: 3255
  • Thanked: 171
  • Model: Galaxy Mk2
  • Spec: 02 tdi 115 ghia
  • Region: South West
  • Country: United Kingdom
Re: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« Reply #10 on: March 27, 2021, 04:54:07 am »
Having thought some more about this ignore what I said above the smax will be BCM controlled so no direct feed from switch to brake lights if it’s anything like other BCM controlled cars. The switch sends a signal to the BCM that then powers the lamps. Usually BCM sends out 2 power supplies. 1 for normal stops and 1 for high level stop. Some cars have a single output from switch some have 2. You would need a circuit drawing to confirm what Ford does.

Also the extra switch could well be for the engine ECU to kill revs if braking,same switch would most likely be used for cruise aswell if your car had it.

As you have main ones working but high level only have a brief flash on test lamp I would be inclined to think it’s a problem with wiring in hatch to the high level brake light and BCM is detecting this so shuts power off.

Been a while since I was in the trade but I don’t think high level brake light is a failure it’s noted as an advisory

Offline brianh

  • Default User Group
  • Accredited Users
  • *
  • Posts: 1118
  • Thanked: 227
  • Model: Galaxy Mk2
  • Spec: 2001 2.3 Ghia LPG
  • First Name: Brian
  • Region: South East
  • Country: United Kingdom
Re: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« Reply #11 on: March 27, 2021, 09:16:21 am »
High level brake light is included in the test with some of the recent changes - It wasn't previously

https://www.gov.uk/guidance/mot-inspection-manual-for-private-passenger-and-light-commercial-vehicles/4-lamps-reflectors-and-electrical-equipment#section-4-3-1

"4.3.1. Presence, condition and operation
You must inspect all stop lamps fitted."

Though with the caveat
"Additional stop lamps, over and above the mandatory requirements, must be tested. However, if you are not sure that they’re connected, you should give the benefit of the doubt."

If it is BCM controlled, then I'm not sure putting any significent load across the switch is a good idea as the switch may not be capable of handling it, it may fail as a result of doing so. Testing with continuity or resistance measurement would be ok using a meter.

I'd expect this is an LED light in your case, and as pointed out further back in the thread, I'd try testing the light directly by putting 12v to it, as its not unknown for them to fail in the manner you describe above. If the light checks out ok then wiring would be the next thing to look at, with the moving section at the hinge point being the place to start.

Offline Eurotrotter

  • Default User Group
  • Standard Users
  • *
  • Posts: 8
  • Thanked: 0
  • Model: S-Max
  • Spec: 2006 1.8 DIESEL
  • First Name: Josh
  • Region: East Anglia
Re: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« Reply #12 on: March 27, 2021, 09:22:56 pm »
Thank you for all your appreciated helpful replies . As advised I have shorted the brake switch connector with a short length of copper and put ignition on . The 2 back lights worked ! But NOT the high level one !
I suspect it has its own feed . From where ? I don't know . It's still a mystery for me as my model is a basic one from the mark 1 series batch ( January 2007 ) . I have ordered a brand new brake light switch and still awaiting delivery . I tested the high level bulb from a 12 V battery via its leads   and it worked , so I suspect the fault lies somewhere in the wiring system . Checked all fuses . All OK . Checked rear wiring looms under concertinas rubbers , found some broken ones , rewired them with correct new connectors but the high level brake light feed still flashes ONLY ONCE on the test probe as if a small amount of current accumulated on its wire and got out when prompted ! I have NO LED lights at all . and NO CRUISE control . I am asking myself what if I bypass a wire from the main brake lights and connect it to the high level one , would that be OK ? As that high level one is really useful for careless drivers behind me who get dangerously too close behind me !!
I could do without it when I receive the new switch . So I am hoping it will work fine.

Offline brianh

  • Default User Group
  • Accredited Users
  • *
  • Posts: 1118
  • Thanked: 227
  • Model: Galaxy Mk2
  • Spec: 2001 2.3 Ghia LPG
  • First Name: Brian
  • Region: South East
  • Country: United Kingdom
Re: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« Reply #13 on: March 27, 2021, 11:24:54 pm »
Looks like the S-Max is an incandescent bulb - if this is your light of course
https://www.ebay.co.uk/itm/Original-3-Brake-Light-Additional-Ford-S-MAX-Galaxy-1745367/174697465409

Does yours have any bulb failure detection? If it does, then linking to the existing brake lights might cause that to throw up errors. Otherwise I can't see an issue with doing that, though it would be nice to kow whats causing the problem in the first place.

Offline johnnyroper

  • RL Contributor
  • Accredited Users
  • *
  • Posts: 3255
  • Thanked: 171
  • Model: Galaxy Mk2
  • Spec: 02 tdi 115 ghia
  • Region: South West
  • Country: United Kingdom
Re: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« Reply #14 on: March 28, 2021, 07:37:52 am »
Thank you for all your appreciated helpful replies . As advised I have shorted the brake switch connector with a short length of copper and put ignition on . The 2 back lights worked ! But NOT the high level one !
I suspect it has its own feed . From where ? I don't know . It's still a mystery for me as my model is a basic one from the mark 1 series batch ( January 2007 ) . I have ordered a brand new brake light switch and still awaiting delivery . I tested the high level bulb from a 12 V battery via its leads   and it worked , so I suspect the fault lies somewhere in the wiring system . Checked all fuses . All OK . Checked rear wiring looms under concertinas rubbers , found some broken ones , rewired them with correct new connectors but the high level brake light feed still flashes ONLY ONCE on the test probe as if a small amount of current accumulated on its wire and got out when prompted ! I have NO LED lights at all . and NO CRUISE control . I am asking myself what if I bypass a wire from the main brake lights and connect it to the high level one , would that be OK ? As that high level one is really useful for careless drivers behind me who get dangerously too close behind me !!
I could do without it when I receive the new switch . So I am hoping it will work fine.

It’s own feed will come from the body control module. I still suspect you have a wiring issue to 3rd brake light and BCM is shutting power off. If you found some broken wires chances are there are more that are broken. Insulation can look fine but the conductor inside is broken.

Offline SirDavidAlhambra

  • Sir David Alhambra.
  • Default User Group
  • Accredited Users
  • *
  • Posts: 897
  • Thanked: 21
  • I am Sir David Alhambra.
  • Model: Alhambra Mk2 Auto
  • Spec: 2006 1.9 Tdi auto
  • First Name: Dave
  • Region: South East
  • Country: United Kingdom
Re: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« Reply #15 on: March 28, 2021, 07:53:55 am »
Yes, that sounds highly logical. Almost like the BCM turns on the power to the upper brake light, detects that there is a something a bit wrong, then turns it off again. I think the issue is likely to be one of high resistance, a cracked wire. For that I would look behind the rubber gaiter on the tailgate. What a tricky conundrum. It possibly drives the upper light from a different circuit so it can more easily detect faults. Sounds to me like checking the wiring is a good idea. Perhaps there is even a fuse that’s on its way out maybe. If you give the rubber gaiter a bit of a jiggle might that make a difference (to help track a possible wiring fault if that is indeed the issue)?
I drive a Seat Alhambra 1.9Tdi which has 115bhp and an automatic gearbox.

I am happy to help you with all your questions. I am not a qualified mechanic but seem to be better at fixing my car than even the most experienced garages.

I have lots of friends here and very much enjoy talking with you all.

Always remember, a motor car is a serious tool and should be treated with respect. Put your safety first, always.

Offline Eurotrotter

  • Default User Group
  • Standard Users
  • *
  • Posts: 8
  • Thanked: 0
  • Model: S-Max
  • Spec: 2006 1.8 DIESEL
  • First Name: Josh
  • Region: East Anglia
Re: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« Reply #16 on: March 28, 2021, 06:32:23 pm »
[ Attachment Invalid Or Does Not Exist ]

Thank you for more helpful tips . I went back to the back gaiter protecting the wires loom, isolated the concerned wire ( i.e high level brake lamp, ) and followed it right down to a junction box where it meets other wires going everywhere and put the prob there where it comes out of the connector . With the ignition ON It STILL gave only ONE flash on my probe and went OFF dead again !
I don't think there's enough chaffing movements or stress down there at rear wing level  to cause a wire break or chaffing .
I think it's feeding from some box I cannot figure out . Haynes manual's circuit diagram is so poorly detailed it's more confusing than helping . I tried to show it attached here where it says high level lamp feed coming down from internal HW ??? What's HW ?? Hot Wire ? 
And so I gave up searching for the high resistance /power leakage fault . I will just wait for the new pedal switch and see if it works . That'll do . [ Attachment Invalid Or Does Not Exist ] [ Attachment Invalid Or Does Not Exist ]

Offline johnnyroper

  • RL Contributor
  • Accredited Users
  • *
  • Posts: 3255
  • Thanked: 171
  • Model: Galaxy Mk2
  • Spec: 02 tdi 115 ghia
  • Region: South West
  • Country: United Kingdom
Re: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« Reply #17 on: March 28, 2021, 07:13:58 pm »
Try running a wire from that junction to the lamp and a seperate good Earth and see if high level light works then?

Offline Eurotrotter

  • Default User Group
  • Standard Users
  • *
  • Posts: 8
  • Thanked: 0
  • Model: S-Max
  • Spec: 2006 1.8 DIESEL
  • First Name: Josh
  • Region: East Anglia
Re: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« Reply #18 on: March 30, 2021, 07:48:01 pm »
Hello to all of you dear friends .
I just wish to share with you that unfortunately I am still stuck with my brake lights problem .
I really am very puzzled and feeling lost as I am finding myself helpless with this seemingly basic problem which has turned into a puzzling hard one !
Despite I replaced the brake light switch at the pedal with a brand new after market one which is called (OE) , it still doesn't work .
It's NOT a fuse issue , because when I short the brake light switch connector , the 2 brake lights at the back light up but stay on as power reaches them continuously.

Could this be a hidden ECU issue ? Went back to Haynes manual and it says : 'You must reset it yourself, ECU will take care of that '. But it didn't . I wonder if there's a connection between the blue switch and the black one which are mounted in the same spot either side of the brake pedal ?
Is there a connection between an absent unused cruise control system circuit ? Is there anything else on the pedal that needs checking or replacing ?

I have never come across such a puzzling electrical problem. Way back 20 years ago it used to be much simpler to fix a brake light .
Any suggestions on a good electrician  may be able to fix it for at reasonable cost please ?

Thank you for any appreciated suggestions         

Offline Eurotrotter

  • Default User Group
  • Standard Users
  • *
  • Posts: 8
  • Thanked: 0
  • Model: S-Max
  • Spec: 2006 1.8 DIESEL
  • First Name: Josh
  • Region: East Anglia
Re: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« Reply #19 on: March 30, 2021, 07:50:41 pm »
PS : ERRATUM :
I meant HAYNES manual says : 'You MUST NOT try reset the switches yourself , as ECU will take care of that 'after a run .
But I didn't do it after a 10 miles run.

Offline johnnyroper

  • RL Contributor
  • Accredited Users
  • *
  • Posts: 3255
  • Thanked: 171
  • Model: Galaxy Mk2
  • Spec: 02 tdi 115 ghia
  • Region: South West
  • Country: United Kingdom
Re: WHY 2 BRAKE PEDAL SWITCHES ? ONE BLUE ONE BLACK ???
« Reply #20 on: March 31, 2021, 08:42:53 am »
Can only be the BCM or wiring broken in my opinion. If I was you I would splice off the working brake light wiring and run new ones to high level and have done with it. Just make sure you disconnect and insulate the existing high level wiring

 

Related Topics

  Subject / Started by Replies Last Post
100 Replies
24168 Views
Last Post February 25, 2013, 01:52:13 pm
by Mirez
5 Replies
4795 Views
Last Post October 14, 2013, 05:36:23 pm
by Fraz-ktf
17 Replies
6074 Views
Last Post May 10, 2014, 12:19:26 pm
by madmanc
1 Replies
2622 Views
Last Post September 05, 2016, 10:45:42 pm
by johnnyroper
3 Replies
2730 Views
Last Post April 01, 2017, 06:52:27 am
by johnnyroper
6 Replies
4841 Views
Last Post July 04, 2017, 08:57:41 pm
by lambretta man

Advertisement: